Cyberduck Mountain Duck CLI

#6613 closed defect (worksforme)

Files uploaded with zero bytes content length

Reported by: Info (4) Owned by: dkocher
Priority: highest Milestone:
Component: cloudfiles Version: 4.2.1
Severity: critical Keywords:
Cc: tomgmitchell@… Architecture:
Platform: Mac OS X 10.7

Description (last modified by dkocher)

Hi,

I have contacted you regarding this issue before http://trac.cyberduck.ch/ticket/6553.

I have been trying to upload the images folder to my Rackspace CDN using Cyberduck.

There is one particular folder that is giving me all the issues. The directory of this folder is /img/p/.

If I attempt to upload the entire img folder, the p folder will fail.

If I attempt to upload the p folder by itself, the upload will fail. The directories will be made, but the actual files will be 0 bytes.

If I attempt to upload the sub folders of p individually, they work.

I have run the following permissions commands on the p directory, to make sure it wasn't a permissions issue:

chmod -R 0755 .
chmod -R g-s .
chmod -R u-s .
chmod -R -t .
setfacl -R -b .
find . -type f -exec chmod 0644 {} \;

When I do this upload using fireuploader for Firefox, the upload is fine.

I would prefer to use Cyberduck as I use it for my default FTP and it has the ability to sync folders, which I'm hoping to do with this CDN.

The last issue was simply closed, however since then I have involved my site developer, my sites host Webfaction and Rackspace to help me solve this issue. However, I believe the issue is somewhere within cyberduck and how it is interacting with this specific folder.

I'm hoping to solve this issue soon, as its a waste for me to be paying for Rackspace CDN files, if I'm not able to use them. And that's been the case for the last 5 weeks.

I can email the toggle drawer, but I didn't want to include it here, as it might include my security info.

Regards,

Tom @tomgmitchell (twitter)

Change History (12)

comment:1 Changed on Apr 2, 2012 at 9:45:59 AM by yla

Please send the transcript from the log drawer (⌘-L) to feedback@…

comment:2 Changed on Apr 2, 2012 at 3:04:44 PM by dkocher

Thanks for the transcript. From the log I can see that the files are seen to have a size (content length) of zero bytes. Are these indeed empty files or is there any difference with these files on the local filesystem; e.g. symbolic links or aliases.

comment:3 Changed on Apr 2, 2012 at 3:06:32 PM by dkocher

  • Summary changed from Upload of IMG file to Rackspace CDN failing to Files uploaded with zero bytes content length

comment:4 Changed on Apr 3, 2012 at 3:16:14 AM by Info (4)

The files should all contain data, but they are transferring as 0 bytes.

The directories and files are being created, but no data transferred.

comment:5 follow-up: Changed on May 1, 2012 at 8:13:35 AM by dkocher

Can you post the output of ls -la of the files in question.

comment:6 Changed on May 1, 2012 at 10:08:19 AM by dkocher

  • Description modified (diff)

comment:7 in reply to: ↑ 5 Changed on May 1, 2012 at 10:08:54 AM by dkocher

Replying to dkocher:

Can you post the output of ls -la of the files in question.

In a Terminal.app window where you also run the chmod command.

comment:8 Changed on May 4, 2012 at 7:29:54 AM by dkocher

Can you additionally post the error message displayed in Cyberduck (if any) for the upload and any related output in the system.log (/Applications/Utilities/Console.app)?

comment:9 Changed on May 21, 2012 at 6:17:26 PM by dkocher

  • Milestone set to 4.3
  • Status changed from new to assigned

comment:10 Changed on Jun 15, 2012 at 1:51:30 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:11 Changed on Jun 16, 2012 at 12:45:18 AM by Tomgmitchell

I've just tried to upload my img/p folder again. It lists the directories, but then has 'upload failed' for every file.

I was going to include the log drawer's info, but I don't want all my token id's exposed to the web.

What should I do?

comment:12 Changed on Mar 22, 2013 at 10:28:15 AM by dkocher

  • Milestone 4.4 deleted
Note: See TracTickets for help on using tickets.
swiss made software