Cyberduck Mountain Duck CLI

#6638 closed defect (thirdparty)

Swipe between pages causes crash in Mac OS Lion

Reported by: ayyoitsp Owned by: dkocher
Priority: normal Milestone:
Component: interface Version: 4.2.1
Severity: critical Keywords: crash, swipe
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

Using the "Swipe between pages" trackpad gesture in Mac OS Lion causes Cyberduck to immediately crash.

Steps to reproduce:

  1. Set up swipe (Mac OS System Preferences -> Trackpad -> More Gestures -> "Swipe between pages"
  2. Start cyberduck
  3. Open connection to any server
  4. Utilize the "swipe between pages" gesture as configured in step 1

What happens: Cyberduck crashes (crash log attached)

Expected result: window updates as if user has clicked the navigation right arrow on swipe right, and navigation left arrow on swipe left

and no crash

Attachments (1)

cyberduckcrash.txt (72.4 KB) - added by ayyoitsp on Apr 16, 2012 at 6:00:05 PM.

Download all attachments as: .zip

Change History (6)

Changed on Apr 16, 2012 at 6:00:05 PM by ayyoitsp

comment:1 Changed on Apr 16, 2012 at 6:02:38 PM by ayyoitsp

This is happening in Version 4.2.1 (9350)

comment:2 Changed on Apr 16, 2012 at 6:10:33 PM by yla

  • Component changed from core to interface
  • Milestone set to 4.3
  • Owner set to dkocher

comment:3 Changed on Apr 16, 2012 at 11:51:44 PM by dkocher

  • Status changed from new to assigned

comment:4 Changed on Jun 21, 2012 at 3:53:55 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from assigned to closed

Thanks for attaching the crash report. The bug is caused by a software called "multiclutchinputmanager" installed on your system. Try to remove this software from your system.

comment:5 Changed on Mar 22, 2013 at 10:11:37 AM by dkocher

  • Milestone 4.4 deleted
Note: See TracTickets for help on using tickets.