Cyberduck Mountain Duck CLI

#6659 closed defect (worksforme)

Copy & Paste copying wrong files

Reported by: dkulp Owned by: dkocher
Priority: normal Milestone: 4.3
Component: s3 Version: 4.2.1
Severity: critical Keywords:
Cc: Architecture:
Platform: Mac OS X 10.7

Description

This is just a heads-up to what is a critical bug regarding incorrect copy/paste behavior. When I paste to a selected directory, CyberDuck copies from the wrong location. In our case we have multiple s3 buckets with sometimes 1000s of keys so I can see a buggy copy/paste displayed in the progress line as hundreds of files being copied. I have to disconnect to stop the copying and I then I find a directory full of files that I didn't intend to copy.

I wish I had more specific description of the problem, but I have observed the behavior several times using CyberDuck and my colleague also observed the same behavior. Even though I don't have the exact details to reproduce it, the problem seems so severe that I wanted to give you a notice. My colleague and I suspect that there is an internal data structure of cached s3 keys and that the paste operation is accidentally referencing the wrong data.

Change History (2)

comment:1 Changed on May 9, 2012 at 10:18:32 AM by dkocher

  • Component changed from core to s3
  • Milestone set to 4.3
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Nov 26, 2012 at 5:19:15 PM by dkocher

  • Milestone changed from 4.3 to 4.2.2
  • Resolution set to worksforme
  • Status changed from assigned to closed
  • Summary changed from Improper copying to Copy & Paste copying wrong files

I cannot reproduce this issue with the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software