Cyberduck Mountain Duck CLI

#6662 closed defect (fixed)

Interoperability with Oracle Java SE 7

Reported by: F Calboli Owned by: dkocher
Priority: high Milestone: 4.4
Component: core Version: 4.2.1
Severity: major Keywords: java
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description

Since Oracle is now going to look after java for Mac, I installed Java SE7 from

http://www.oracle.com/technetwork/java/javase/downloads/index.html

and it is now the only java on my machine (I still have Apple java, but I unticked it in java prefs), to avoid crapware thanks to Apple not patching java on time. Unfortunately Cyberduck does not like ut:

Cannot launch “Cyberduck” No compatible version of Java 1.5+ is available.

This is a major PITA especially in view of migrating java support to oracle, and avoiding Apple lazy approach to security.

I'm on Lion, latest everything (OS, Cyberduck, whatnot).

Change History (9)

comment:1 Changed on May 2, 2012 at 8:02:33 PM by dkocher

  • Milestone set to 4.3
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from cyberduck does not like java SE 7 to Interoperability with Oracle Java SE 7

comment:2 Changed on May 21, 2012 at 1:28:41 PM by dkocher

This is blocked by MACOSX_PORT-99.

comment:3 Changed on Sep 26, 2012 at 9:30:49 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

We have added support in r9742. This will however not be enabled by default as long as we must support Java 6 installations (we cannot support both at the same time). In the long run we bundle the JVM for all installations as we already do for the Mac App Store version.

comment:4 Changed on Sep 26, 2012 at 4:50:06 PM by dkocher

  • Milestone changed from 4.3 to 4.2.2

comment:5 Changed on Mar 24, 2013 at 3:39:57 PM by dkocher

  • Milestone changed from 4.3 to 4.4

comment:6 Changed on Apr 30, 2013 at 2:26:20 PM by dkocher

The latest snapshot build for Mac now requres OS X 10.6 or later, a 64Bit Intel Processor [1] but no Java installation requirement.

[1] http://support.apple.com/kb/ht3696

comment:7 Changed on May 2, 2013 at 2:42:42 PM by dkocher

#7196 closed as duplicate.

comment:8 Changed on Jun 27, 2013 at 10:10:33 PM by dkocher

  • Milestone changed from 4.5 to 4.4

comment:9 Changed on Oct 24, 2013 at 8:19:45 AM by dkocher

#7502 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software