Cyberduck Mountain Duck CLI

#6669 closed defect (fixed)

Modification Time Lost

Reported by: littlefyr Owned by: dkocher
Priority: high Milestone: 4.3
Component: ftp Version: 4.2.1
Severity: major Keywords:
Cc: Architecture:
Platform: Mac OS X 10.7

Description

It happens with some frequency that if I edit-in-place some text file with TextMate that the modified time on the remote machine is something in 1969 which I suspect is just being set to 0. This isn't normally a big deal except that one machine this happens on has a script that seems to be throwing up when the modified time is in this state.

Change History (9)

comment:1 Changed on May 4, 2012 at 7:26:05 PM by littlefyr

  • Platform set to Mac OS X 10.7

comment:2 Changed on May 9, 2012 at 11:10:33 AM by dkocher

  • Component changed from core to ftp
  • Resolution set to worksforme
  • Status changed from new to closed

Try to check Preferences → Transfers → Uploads → Preserve modification date.

comment:3 Changed on May 9, 2012 at 6:06:26 PM by littlefyr

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I should have made that clear.... preserve modification date for both upload and download are checked.

comment:4 Changed on May 9, 2012 at 6:14:00 PM by dkocher

Can you please post the transcript from the log drawer (⌘-L) of the Transfers window.

comment:5 Changed on May 9, 2012 at 6:14:06 PM by dkocher

  • Milestone set to 4.3

comment:6 Changed on May 9, 2012 at 7:40:50 PM by littlefyr

The problem is that this doesn't always happen. It only happens on occasion. I'll try a few things and then, if it doesn't occur in the next few minutes, I'll have to keep my eye out for it during my normal work.

comment:7 Changed on Jul 10, 2012 at 4:30:56 PM by littlefyr

Well it took 2 months but I finally had this happen again. Fortunately I've been keeping the log drawer open by default so i could find it.

Here's the extended segment of the log showing the problem:

226 File sent ok.
NOOP
200 NOOP command successful.
STAT /GW_Web
211-Status
 drwxrwxrwx   1 user     group        8192 Jul 05 10:12 .
 drwxrwxrwx   1 user     group           0 May 04 09:21 ..
 drwxrwxrwx   1 user     group           0 May 04  2011 _newsletters
 drwxrwxrwx   1 user     group           0 Feb 14 15:35 css
 drwxrwxrwx   1 user     group           0 May 06  2011 dealmate
 -rw-rw-rw-   1 user     group          61 Apr 26  2007 editrobots.txt
 drwxrwxrwx   1 user     group           0 Dec 09  2010 entertainment subcat
 drwxrwxrwx   1 user     group           0 Nov 22  2010 export
 drwxrwxrwx   1 user     group           0 Oct 12  2011 exportTemplates
 drwxrwxrwx   1 user     group           0 Aug 05  2010 flowplayer
 -rw-rw-rw-   1 user     group          53 Apr 06  2011 googleaae7ce46e16f73f0.html
 -rw-rw-rw-   1 user     group          53 Apr 11  2011 googleb650184627e5391a.html
 -rw-rw-rw-   1 user     group          53 Apr 05  2011 googlee32ec7973dcffde6.html
 -rw-rw-rw-   1 user     group          53 Jun 21  2010 googlef5947eeb567be0ea.html
 drwxrwxrwx   1 user     group           0 Jun 11  2009 graphics
 -rw-rw-rw-   1 user     group   371499540 Jul 02 13:03 GW.zip
 -rw-rw-rw-   1 user     group          22 Mar 17  2009 gw_RNR.txt
 drwxrwxrwx   1 user     group           0 Jan 18 20:05 images
 drwxrwxrwx   1 user     group           0 Feb 07 18:38 includes
 drwxrwxrwx   1 user     group           0 Oct 31  2009 js
 drwxrwxrwx   1 user     group           0 Mar 09  2011 json
 drwxrwxrwx   1 user     group           0 Jul 12  2011 landing
 -rw-rw-rw-   1 user     group        5383 May 10 20:16 LILLOOET_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        2917 Jun 21  2010 lillooet_sitemap.xml
 -rw-rw-rw-   1 user     group       58266 Jul 10 11:06 localdata.ini
 drwxrwxrwx   1 user     group           0 Feb 07  2011 logs
 drwxrwxrwx   1 user     group           0 Mar 10  2009 marketplace
 drwxrwxrwx   1 user     group           0 Mar 07  2011 misc
 drwxrwxrwx   1 user     group           0 Mar 09  2011 Mobi
 -rw-rw-rw-   1 user     group        3535 Oct 20  2010 nolist.txt
 drwxrwxrwx   1 user     group           0 Feb 01 19:13 pdf
 -rw-rw-rw-   1 user     group        7959 Feb 14 16:39 POWELLRIVER_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        4073 Jul 05 10:12 publicus.ini
 -rw-rw-rw-   1 user     group        2992 Apr 25 20:22 publicus.ini.20120503.my
 -rw-rw-rw-   1 user     group        4028 Jul 05 10:05 publicus.ini.20120705.sjp
 -rw-rw-rw-   1 user     group        4028 May 21 11:24 publicus.ini.bak
 -rw-rw-rw-   1 user     group        2740 Jan 31 12:42 publicus.ini_20120131sjp
 -rw-rw-rw-   1 user     group        2773 Feb 01 10:13 publicus.ini_20120201kmn
 -rw-rw-rw-   1 user     group        2770 Feb 02 13:00 publicus.ini_20120202sjp
 -rw-rw-rw-   1 user     group        2724 Feb 09 11:41 publicus.ini_20120209sjp
 -rw-rw-rw-   1 user     group          24 Jul 14  2009 robots.txt
 -rw-rw-rw-   1 user     group          41 Dec 10  2009 robots_coastreporter.txt
 -rw-rw-rw-   1 user     group          42 Dec 10  2009 robots_squamishchief.txt
 -rw-rw-rw-   1 user     group        5616 Apr 05 18:25 SECHELT_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3451 Jun 21  2010 sechelt_sitemap.xml
 -rw-rw-rw-   1 user     group        6561 May 17 02:46 SQUAMISH_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3834 Jun 21  2010 squamish_sitemap.xml
 drwxrwxrwx   1 user     group           0 Jun 13 02:13 templates
 -rw-rw-rw-   1 user     group        6008 Apr 05 18:25 WHISTLER_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3781 Jun 21  2010 whistler_sitemap.xml
 -rw-rw-rw-   1 user     group        3649 May 28 13:26 WHISTLERMAGAZINE_sitehierarchy.xml
 -rw-rw-rw-   1 user     group         869 Mar 15  2011 whistlermagazine_sitemap.xml
 -rw-rw-rw-   1 user     group        4913 Sep 19  2008 WQ_siteMap.xml
211 End of status
NOOP
200 NOOP command successful.
TYPE I
200 Type set to I.
PASV
227 Entering Passive Mode (205,139,40,141,218,185)
RETR /GW_Web/localdata.ini
150 Data connection accepted from 24.84.196.223:50253; transfer starting for /GW_Web/localdata.ini (58266 bytes)
226 File sent ok.
NOOP
200 NOOP command successful.
TYPE I
200 Type set to I.
PASV
227 Entering Passive Mode (205,139,40,141,9,185)
STOR /GW_Web/localdata.ini
150 Data connection accepted from 24.84.196.223:50255; transfer starting for /GW_Web/localdata.ini
226 File received ok.
NOOP
200 NOOP command successful.
SITE CHMOD 666 /GW_Web/localdata.ini
200 CHMOD command successful.
MFMT 19700101000000 /GW_Web/localdata.ini
213 Modify=19700101000000; /GW_Web/localdata.ini
NOOP
200 NOOP command successful.
STAT /GW_Web
211-Status
 drwxrwxrwx   1 user     group           0 Jul 05 10:12 .
 drwxrwxrwx   1 user     group           0 May 04 09:21 ..
 drwxrwxrwx   1 user     group           0 May 04  2011 _newsletters
 drwxrwxrwx   1 user     group           0 Feb 14 15:35 css
 drwxrwxrwx   1 user     group           0 May 06  2011 dealmate
 -rw-rw-rw-   1 user     group          61 Apr 26  2007 editrobots.txt
 drwxrwxrwx   1 user     group           0 Dec 09  2010 entertainment subcat
 drwxrwxrwx   1 user     group           0 Nov 22  2010 export
 drwxrwxrwx   1 user     group           0 Oct 12  2011 exportTemplates
 drwxrwxrwx   1 user     group           0 Aug 05  2010 flowplayer
 -rw-rw-rw-   1 user     group          53 Apr 06  2011 googleaae7ce46e16f73f0.html
 -rw-rw-rw-   1 user     group          53 Apr 11  2011 googleb650184627e5391a.html
 -rw-rw-rw-   1 user     group          53 Apr 05  2011 googlee32ec7973dcffde6.html
 -rw-rw-rw-   1 user     group          53 Jun 21  2010 googlef5947eeb567be0ea.html
 drwxrwxrwx   1 user     group           0 Jun 11  2009 graphics
 -rw-rw-rw-   1 user     group   371499540 Jul 02 13:03 GW.zip
 -rw-rw-rw-   1 user     group          22 Mar 17  2009 gw_RNR.txt
 drwxrwxrwx   1 user     group           0 Jan 18 20:05 images
 drwxrwxrwx   1 user     group           0 Feb 07 18:38 includes
 drwxrwxrwx   1 user     group           0 Oct 31  2009 js
 drwxrwxrwx   1 user     group           0 Mar 09  2011 json
 drwxrwxrwx   1 user     group           0 Jul 12  2011 landing
 -rw-rw-rw-   1 user     group        5383 May 10 20:16 LILLOOET_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        2917 Jun 21  2010 lillooet_sitemap.xml
 -rw-rw-rw-   1 user     group       58458 Dec 31  1969 localdata.ini
 drwxrwxrwx   1 user     group           0 Feb 07  2011 logs
 drwxrwxrwx   1 user     group           0 Mar 10  2009 marketplace
 drwxrwxrwx   1 user     group           0 Mar 07  2011 misc
 drwxrwxrwx   1 user     group           0 Mar 09  2011 Mobi
 -rw-rw-rw-   1 user     group        3535 Oct 20  2010 nolist.txt
 drwxrwxrwx   1 user     group           0 Feb 01 19:13 pdf
 -rw-rw-rw-   1 user     group        7959 Feb 14 16:39 POWELLRIVER_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        4073 Jul 05 10:12 publicus.ini
 -rw-rw-rw-   1 user     group        2992 Apr 25 20:22 publicus.ini.20120503.my
 -rw-rw-rw-   1 user     group        4028 Jul 05 10:05 publicus.ini.20120705.sjp
 -rw-rw-rw-   1 user     group        4028 May 21 11:24 publicus.ini.bak
 -rw-rw-rw-   1 user     group        2740 Jan 31 12:42 publicus.ini_20120131sjp
 -rw-rw-rw-   1 user     group        2773 Feb 01 10:13 publicus.ini_20120201kmn
 -rw-rw-rw-   1 user     group        2770 Feb 02 13:00 publicus.ini_20120202sjp
 -rw-rw-rw-   1 user     group        2724 Feb 09 11:41 publicus.ini_20120209sjp
 -rw-rw-rw-   1 user     group          24 Jul 14  2009 robots.txt
 -rw-rw-rw-   1 user     group          41 Dec 10  2009 robots_coastreporter.txt
 -rw-rw-rw-   1 user     group          42 Dec 10  2009 robots_squamishchief.txt
 -rw-rw-rw-   1 user     group        5616 Apr 05 18:25 SECHELT_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3451 Jun 21  2010 sechelt_sitemap.xml
 -rw-rw-rw-   1 user     group        6561 May 17 02:46 SQUAMISH_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3834 Jun 21  2010 squamish_sitemap.xml
 drwxrwxrwx   1 user     group           0 Jun 13 02:13 templates
 -rw-rw-rw-   1 user     group        6008 Apr 05 18:25 WHISTLER_sitehierarchy.xml
 -rw-rw-rw-   1 user     group        3781 Jun 21  2010 whistler_sitemap.xml
 -rw-rw-rw-   1 user     group        3649 May 28 13:26 WHISTLERMAGAZINE_sitehierarchy.xml
 -rw-rw-rw-   1 user     group         869 Mar 15  2011 whistlermagazine_sitemap.xml
 -rw-rw-rw-   1 user     group        4913 Sep 19  2008 WQ_siteMap.xml
211 End of status
NOOP
200 NOOP command successful.

So I did ⌘-K to edit localdata.ini file and let it save. The modification time is clearly Jan 1, 1970. I'm not sure who is responsible for deciding the modification time in this case (cyberduck or textmate), but it would seem that some sort of alert/confirmation could be presented verifying the modification date when it 0ms (perhaps with the option to set the timestamp) would be advisable since its rarely the case that files these days are modified in 1970.

comment:8 Changed on Jul 10, 2012 at 7:19:17 PM by dkocher

  • Owner set to dkocher
  • Status changed from reopened to new

comment:9 Changed on Oct 10, 2012 at 9:02:24 PM by dkocher

  • Milestone changed from 4.3 to 4.2.2
  • Resolution set to fixed
  • Status changed from new to closed

In r9795. This was a concurrency issue with usage of non thread safe classes.

Note: See TracTickets for help on using tickets.
swiss made software