Cyberduck Mountain Duck CLI

#6690 closed defect (worksforme)

Uploaded files are empty on the server (file size is 0)

Reported by: dispiste Owned by: yla
Priority: normal Milestone: 4.3
Component: webdav Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows XP

Description

Whenever I try to upload a file from cyberduck to my WebDAV server (running Apache), the resulting file is empty (file size is 0 bytes) on the server. No error is reported by cyberduck.

I can successfully upload files using other clients (BitKinex, Konqueror).

If necessary, I can provide a test access for developers (for a limited time).

Attachments (1)

log.txt (2.3 KB) - added by dispiste on May 18, 2012 at 1:28:15 PM.
Transfer log

Download all attachments as: .zip

Change History (7)

comment:1 Changed on May 18, 2012 at 12:33:24 PM by dkocher

Can you please post the transcript from the Transfers window. Add the Log item by right click on the toolbar to open the log.

Changed on May 18, 2012 at 1:28:15 PM by dispiste

Transfer log

comment:2 Changed on May 18, 2012 at 1:29:13 PM by dispiste

I have attached the log. Note that I have obscured the server name.

comment:3 Changed on Oct 10, 2012 at 8:37:15 PM by dkocher

  • Milestone set to 4.2.2
  • Owner changed from dkocher to yla

We send Content-Length: 0 for the file uploaded to https://whaterverserver/webdav/gis_sdi_sample_xml_reference.xml. This indicates that we are not reading the file size on the local volume correctly.

comment:4 Changed on Oct 11, 2012 at 5:22:39 PM by dkocher

This could also be a duplicate of #6761.

comment:5 Changed on Dec 17, 2012 at 4:07:27 PM by dkocher

Can you reproduce this issue with the latest snapshot build available?

comment:6 Changed on Dec 26, 2012 at 6:15:24 PM by yla

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.