Cyberduck Mountain Duck CLI

#6710 closed enhancement (worksforme)

Selecting files by typing is not consistent with behaviour in Finder.app

Reported by: Chocolate Camera Owned by: dkocher
Priority: low Milestone: 4.4
Component: interface Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Summary

When in a window with a list of files, selecting a file by typing its filename is not consistent with how the Finder does it:

  1. Typing a letter no file starts with, causes an alert sound. The Finder selects the alphabetically following closest file.
  2. The timeout to reset the search (i.e. interpreting that a typed letter is the first in the filename instead of the following to the previously typed) is longer than the Finder's. The Finder's seems to be 1 sec. Cyberducks seems to be around 2 sec.
  3. If more than one file starts with that letter, typing the letter again will select the following file. The Finder will not alter the current selection.

How to reproduce

  1. Open an FTP window, create a folder, enter it and create the following files:
    • AAA
    • CCC
    • CDD
    • CEE
    • DDD
  1. Type B.
  2. After 2 sec, type C.
  3. After 2 sec, type C again.
  4. After 1 sec but before 2 sec, type D.
  5. After 2 sec, type D

Result

  1. Will cause an alert sound
  2. Will select CCC
  3. Will change selection to CDD
  4. Will keep CDD selected
  5. Will change selection to DDD

Expected results

  1. Should select CCC
  2. Works as expected
  3. Should keep CCC selected
  4. Should change selection to DDD
  5. Worked as expected.

Plaform

Versión 4.2.1 (9350) on Mac OS X 10.6.8

Change History (5)

comment:1 Changed on Jun 5, 2012 at 10:04:37 AM by Chocolate Camera

  • Summary changed from Autoscrolling/selecting by typing filename produces alert if no match to Selecting files by typing is not consistent with Finder's behavior

comment:2 Changed on Oct 10, 2012 at 2:22:42 PM by dkocher

  • Component changed from core to interface
  • Owner set to dkocher

comment:3 Changed on Oct 10, 2012 at 2:25:59 PM by dkocher

  • Summary changed from Selecting files by typing is not consistent with Finder's behavior to Selecting files by typing is not consistent with behaviour in Finder.app

comment:4 Changed on Oct 10, 2012 at 8:38:03 PM by dkocher

  • Priority changed from normal to low
  • Type changed from defect to enhancement

comment:5 Changed on Sep 10, 2013 at 7:51:30 PM by dkocher

  • Milestone set to 4.4
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this issue as we are using the standard type ahead selection feature of the Cocoa user interface components since some time now (r5645). The behaviour should therefore be consistent with other applications.

Note: See TracTickets for help on using tickets.
swiss made software