Cyberduck Mountain Duck CLI

#6751 closed defect (worksforme)

Cyberduck not starting (bounce...)

Reported by: Sasha Blumer Owned by:
Priority: normal Milestone: 4.3
Component: core Version: 4.2.1
Severity: normal Keywords: OS X lion, bouncing, not starting
Cc: Architecture:
Platform:

Description

Macbook Pro, late 2008, latest Java for Lion OS X Lion 10.7.4

Cyberduck mostly just bounces in the Dock. Sometimes (rarely) after a force-shutdown of the app, Cyberduck will restart again.

Tried these solutions: Reinstalled latest Java for OS X Lion. Cleared Caches, ran croncobs, etc ... I even deleted Cyberduck-app, and bought it in the appstore, hoping the installation-routine would improve the start-behaviour.

But nothing changed, except me spending 24.-sFr, although i had a registered copy (by supporting the cool app before) ...

hope I don't get a "worksforme"-status, because ... for me Cyberduck sure doesn't work (starts) as needed anymore.

Change History (9)

comment:1 Changed on Jul 16, 2012 at 10:24:36 AM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 Changed on Jul 16, 2012 at 10:24:43 AM by dkocher

  • Milestone set to 4.2.2

comment:3 Changed on Jul 19, 2012 at 11:21:34 AM by Sasha Blumer

Hmm, not sure if this is, what you need:

16.07.12 18:30:30.876 [0x0-0x5f05f].ch.sudo.cyberduck: Jul 16 18:30:30 mys.local Cyberduck[1785] <Error>: CGContextGetCTM: invalid context 0x0
16.07.12 18:30:30.876 [0x0-0x5f05f].ch.sudo.cyberduck: Jul 16 18:30:30 mys.local Cyberduck[1785] <Error>: CGContextSetBaseCTM: invalid context 0x0
16.07.12 18:30:30.902 [0x0-0x5f05f].ch.sudo.cyberduck: Jul 16 18:30:30 mys.local Cyberduck[1785] <Error>: CGContextGetCTM: invalid context 0x0
16.07.12 18:30:30.902 [0x0-0x5f05f].ch.sudo.cyberduck: Jul 16 18:30:30 mys.local Cyberduck[1785] <Error>: CGContextSetBaseCTM: invalid context 0x0

Last edited on Sep 26, 2012 at 2:52:59 PM by dkocher (previous) (diff)

comment:4 Changed on Sep 26, 2012 at 2:55:06 PM by dkocher

Does the application eventually start or not? The version from the Mac App Store does not make use of the installed Java version.

comment:5 Changed on Sep 26, 2012 at 5:02:45 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:6 Changed on Sep 26, 2012 at 5:03:09 PM by dkocher

  • Milestone 4.2.2 deleted

Sorry for the delay in responding to this issue. Please reopen if the issue still persists.

comment:7 Changed on Sep 26, 2012 at 6:16:36 PM by Sasha Blumer

I installed via AppleStore, before I had it via your website.

But the problem persists, no matter what Java I install (I keep updating to the latest Java for Mac OS X).

Sometimes I can start Cyberduck, after killing the stuck process (mit "sofort beenden"), and restarting it again. The first attempt to start Cyberduck allways fails. The second works, ... sometimes.

.. so Cyberduck for me is only starting every now and then.

A fix would be welcome, since I don't want to change to another app, after using Cyberduck for years.

Thanks

Last edited on Sep 26, 2012 at 6:17:48 PM by Sasha Blumer (previous) (diff)

comment:8 follow-up: Changed on Oct 4, 2012 at 7:24:25 PM by dkocher

  • Milestone set to 4.2.2

I suspect this to be a duplicate of #6814. Please update to the latest snapshot build available.

comment:9 in reply to: ↑ 8 Changed on Oct 7, 2012 at 9:25:46 AM by Sasha Blumer

Replying to dkocher:

I suspect this to be a duplicate of #6814. Please update to the latest snapshot build available.

Well ... the point is: If you download Cyberduck from the Applestore there is no "Update"-item/icon within the "preferences"-Pane. So there's no chance to get the "snapshot"-builds this way ... I have two versions on different Macs, the version downloaded from cyberduck.ch has the "Update"-Settings option, the one downloaded from the Applestore does not ...

Note: See TracTickets for help on using tickets.
swiss made software