Cyberduck Mountain Duck CLI

#6759 closed defect (worksforme)

Crash on file duplication after idle

Reported by: Gehzumteufel Owned by: dkocher
Priority: normal Milestone: 4.3
Component: sftp Version: 4.2.1
Severity: major Keywords: crash, idle, reconnect, duplicate
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Cyberduck will consistently crash if left idle and then you attempt to duplicate a file. It crashes on connect because the connection has been terminated either locally or remotely due to idle. The time at which it crashes is once I have hit duplicate to submit for the dupe to be created and it attempts to just automatically upload the file instead of checking for an active connection first and determining what to do next depending on the results.

I can avoid this if I remember to refresh the directory listing before I use the dupe option.

This has been a problem on OS X 10.6 and 10.7.

Change History (4)

comment:1 Changed on Jul 19, 2012 at 8:35:17 AM by dkocher

  • Milestone set to 4.2.2

comment:2 Changed on Oct 6, 2012 at 10:34:01 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with the latest snapshot build available. .

comment:3 Changed on Nov 1, 2012 at 3:19:49 PM by dkocher

Also reported in #6934.

comment:4 Changed on Nov 1, 2012 at 3:20:12 PM by dkocher

Thanks for your bug report. Can you reproduce this issue with the latest snapshot build available?

Note: See TracTickets for help on using tickets.
swiss made software