Cyberduck Mountain Duck CLI

#6775 closed defect (worksforme)

Resource Not Found errors

Reported by: david33409 Owned by:
Priority: normal Milestone:
Component: core Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I Installed the latest JDK from Oracle's web site for Mac OSX Lion 10.7.4. I was able to finally compile the app. I'm now getting the following errors when trying to launch CyberDuck.app

Resource not found for: core.jar
Resource not found for: ui.jar
Resource not found for: cocoa.jar
Resource not found for: log4j-1.2.15.jar
Resource not found for: icu4j-module-4.4.1.1.jar
Resource not found for: jdom-1.1.jar
Resource not found for: jakarta-oro-2.0.8.jar
Resource not found for: commons-net-ftp-3.0.1.jar
Resource not found for: commons-collections-3.2.1.jar
Resource not found for: commons-logging-1.1.1.jar
Resource not found for: commons-codec-1.4.jar
Resource not found for: jets3t-0.8.2.jar
Resource not found for: cloudfiles-1.9.1.jar
Resource not found for: commons-lang-2.4.jar
Resource not found for: commons-io-2.0.1.jar
Resource not found for: java-xmlbuilder-0.4.jar
Resource not found for: jna-3.3.0.jar
Resource not found for: asm-3.3.1.jar
Resource not found for: cglib-2.2.jar
Resource not found for: slf4j-log4j12-1.6.1.jar
Resource not found for: slf4j-api-1.6.1.jar
Resource not found for: jul-to-slf4j-1.6.1.jar
Resource not found for: dns_sd.jar
Resource not found for: backport-util-concurrent-3.1.jar
Resource not found for: gdata-core-1.0.jar
Resource not found for: gdata-client-1.0.jar
Resource not found for: gdata-client-meta-1.0.jar
Resource not found for: gdata-media-1.0.jar
Resource not found for: gdata-docs-3.0.jar
Resource not found for: gdata-docs-meta-3.0.jar
Resource not found for: gdata-spreadsheet-3.0.jar
Resource not found for: gdata-spreadsheet-meta-3.0.jar
Resource not found for: google-collect-1.0.jar
Resource not found for: mail-1.4.3.jar
Resource not found for: activation-1.1.1.jar
Resource not found for: httpcore-4.1.3.jar
Resource not found for: httpclient-4.1.2.jar
Resource not found for: httpmime-4.1.2.jar
Resource not found for: dom4j-1.6.1.jar
Resource not found for: jaxen-1.1.1.jar
Resource not found for: signpost-core-1.2.1.1.jar
Resource not found for: signpost-commonshttp4-1.2.1.1.jar
Resource not found for: json-simple-1.1.jar
Resource not found for: apache-mime4j-0.6.jar
Resource not found for: bcprov-jdk15-145.jar
Resource not found for: bcmail-jdk15-145.jar
Resource not found for: sardine-321.jar
Resource not found for: jaxb-api-2.2.2.jar
Resource not found for: jaxb-impl-2.2.2.jar
Resource not found for: stax-api-1.0-2.jar
Resource not found for: ganymed-ssh-2-260.jar
Resource not found for: azure-8.jar
Resource not found for: jackson-core-asl-1.9.2.jar
Resource not found for: jackson-mapper-asl-1.9.2.jar
Exception in thread "main" java.lang.NoClassDefFoundError: ch/cyberduck/ui/cocoa/MainApplication
Caused by: java.lang.ClassNotFoundException: ch.cyberduck.ui.cocoa.MainApplication
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

Any assistance would be appreciated. Thank you in advance for your time and consideration.

Change History (12)

comment:1 Changed on Jul 24, 2012 at 7:49:29 AM by dkocher

  • Description modified (diff)
  • Resolution set to worksforme
  • Status changed from new to closed

Make sure to build the application with ant.

comment:2 follow-up: Changed on Jul 24, 2012 at 2:57:08 PM by david33409

I have ant installed. I'm using XCODE 4 per the instructions. Please explain your comment. Thank you.

comment:3 in reply to: ↑ 2 Changed on Jul 24, 2012 at 2:59:46 PM by dkocher

Replying to david33409:

I have ant installed. I'm using XCODE 4 per the instructions. Please explain your comment. Thank you.

Which instructions do you follow? Type ant in a Terminal.app window to build.

comment:4 Changed on Jul 24, 2012 at 3:59:14 PM by david33409

Instructions from the read me file. I was under the impression that ant was only used for Windows. I see now it is for both but Windows has an extra step. What is XCODE for if ant is used? Just curious? Is it just to get the files/libraries installed? I ask because that is the environment I typically use for debugging.

comment:5 Changed on Jul 24, 2012 at 4:06:10 PM by david33409

Now I'm getting the error

[BEROR]error: There is no SDK with the name or path '/Volumes/Data Drive/Dev/Apple/CyberDuck/4.2.1/macosx10.5'
Last edited on Jul 27, 2012 at 9:02:53 AM by dkocher (previous) (diff)

comment:6 follow-up: Changed on Jul 24, 2012 at 4:14:15 PM by david33409

FYI I'm using XCODE 4.3.3 and I have OSX 10.7.4 installed.

comment:7 in reply to: ↑ 6 Changed on Jul 27, 2012 at 9:28:58 AM by dkocher

Replying to david33409:

FYI I'm using XCODE 4.3.3 and I have OSX 10.7.4 installed.

Either change the SDK used in the project to what is available on your system or copy the 10.5 and 10.6 SDKs from an older installation and symlink to the current platform environment with

ln -s /Developer/SDKs/MacOSX10.5.sdk /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/

comment:8 Changed on Jul 27, 2012 at 2:01:16 PM by david33409

I've already changed the Cyberduck.xcodeproj to use the latest (10.7) SDK. Everything builds but the app won't run as I've indicated in previous posts. Is there some other place it needs to be changed. I didn't find it in the build-mac.xml. I also performed a search for "10.5" and wasn't able to locate it in any "project" file.

Thank you for your assistance.

comment:9 Changed on Jul 27, 2012 at 3:57:41 PM by david33409

OK I see it was in the libPrime project settings but it doesn't show up in a search of my file system for some reason.

comment:10 follow-up: Changed on Jul 27, 2012 at 4:02:05 PM by david33409

If I use ant to build CyberDuck and create the app, how does one 'debug' and enhancements they would like to make via XCODE? I'm interested in providing a few enhancements to CyberDuck and I'd like to create a prototype first to see if it is possible. Since I'm not familiar with ant I was hoping you might be able to explain how I can use XCODE to build and debug the CyberDuck project. Is it possible?

comment:11 in reply to: ↑ 10 Changed on Jul 27, 2012 at 4:30:34 PM by dkocher

Replying to david33409:

If I use ant to build CyberDuck and create the app, how does one 'debug' and enhancements they would like to make via XCODE? I'm interested in providing a few enhancements to CyberDuck and I'd like to create a prototype first to see if it is possible. Since I'm not familiar with ant I was hoping you might be able to explain how I can use XCODE to build and debug the CyberDuck project. Is it possible?

The ant script uses xcodebuild to execute the targets in the XCode project to compile the native libraries. For the rest of the project you will be much more productive to use a Java IDE (such as IntelliJ) and debug from there. To debug, copy the Info.plist.debug to build/Release/Cyberduck.app/Contents/Info.plist and connect to Java remote debugger to port 5005.

comment:12 Changed on Jul 27, 2012 at 4:58:39 PM by david33409

Thank you I will try that out. So can I assume there is no way to build and debug via Xcode UI?

Note: See TracTickets for help on using tickets.