Cyberduck Mountain Duck CLI

#6853 closed enhancement (wontfix)

Skip resolving IP address when connecting through proxy

Reported by: shammash Owned by: dkocher
Priority: normal Milestone:
Component: webdav Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Hi,

I have a webdav server configured as a hidden service reachable using a .onion address.

I downloaded Cyberduck for Mac, configured it to use system proxy settings, and configured Mac system Proxies to use a local privoxy+tor setup for http.

If I try to connect to my hidden webdav server Cyberduck terminates the connection attempt with a DNS Error.

I didn't check through the code, but the problem seems to be caused by Cyberduck trying to resolve the host name using dns instead of passing the name directly to the http proxy.

If this is the case, please fix Cyberduck to skip dns resolution when an http proxy is configured.

Thank you!

Change History (5)

comment:1 Changed on Sep 11, 2012 at 1:35:05 PM by dkocher

It is correct that we do try to resolve the hostname before attempting to connect to the remote host.

comment:2 Changed on Sep 11, 2012 at 1:35:33 PM by dkocher

As a workaround you could possibly add an entry to /etc/hosts.

comment:3 Changed on Sep 11, 2012 at 1:36:14 PM by dkocher

  • Summary changed from unable to establish a webdav connection with a hidden service (.onion) to Skip resolving IP address when connecting through proxy
  • Type changed from defect to enhancement

comment:4 Changed on Oct 29, 2012 at 5:55:08 PM by dkocher

  • Resolution set to wontfix
  • Status changed from new to closed

comment:5 Changed on Oct 30, 2012 at 11:35:04 AM by shammash

Hi David,

may I ask you why, in your opinion, people use a proxy to access some resources?

Thank you,

Luca

Note: See TracTickets for help on using tickets.