Cyberduck Mountain Duck CLI

#6878 closed defect (fixed)

Application hangs editing file in external editor

Reported by: Lkmnyc Owned by: dkocher
Priority: highest Milestone: 4.3
Component: core Version: 4.2.1
Severity: blocker Keywords: freeze, open file
Cc: Brett, Francis Architecture: Intel
Platform: Mac OS X 10.8

Description

I have tried everything I know but can't figure out if there are preferences on Mac OSX to delete - I haven't found them. I am no longer able to work on the server, i.e., open a file using an external editor (Textwrangler). I get the spinning beach ball and have to force quit.

This is a blocker, thus highest priority for me, because I need to find another FTP app until I can use this again, and Cyberduck is my preferred application.

Any help will be appreciated.

Change History (24)

comment:1 follow-up: Changed on Sep 24, 2012 at 8:08:23 PM by Kkwan4

I have the same issue as well
my environment is : OS X 10.8.2
cyberduck version : 4.2.1
text wrangler version : 4.0.1
smultron version : 3.5

I've noticed the following issue and it's related to Cyberduck opening in text wrangler

  • reboot Mac
  • start Cyberduck (configured for text wrangler)
  • select file to edit
  • Cyberduck launches text wrangler and opens up file


Here's where it gets interesting

  • close text wrangler
  • select file to edit from Cyberduck
  • spinning beach ball shows up


  • kill Cyberduck
  • relaunch Cyberduck and configure external text editor as Smultron
  • select file to edit from Cyberduck
  • works


This appears to be something specific with Text Wrangler and Cyberduck... as Smultron worked.

After playing with this for a while, Smultron has failed to work as well as Text Wrangler. A reboot allows these to work again.

Version 4, edited on Sep 24, 2012 at 9:48:49 PM by Kkwan4 (previous) (next) (diff)

comment:2 Changed on Sep 25, 2012 at 2:37:05 PM by Cowboy

Mac OS 10.8.2, Cyberduck 4.2.1 (tested with release 9350 and 9684), Textwrangler 4.0.1 (release 3152)

Same here.

Found that ticket http://trac.cyberduck.ch/ticket/6093 where it was recommended as a workaround „to disable the ODB editor support and instead work with the file notifications editor support“. Open Terminal:

defaults write ch.sudo.cyberduck editor.odb.enable false

That worked for me. But as I’m just a user, I don’t know what this change finally effects.

PS: Seems to me this problem came up with updating to Mac OS 10.8.2 ...

comment:3 Changed on Sep 25, 2012 at 5:25:32 PM by dkocher

  • Milestone set to 4.2.2

comment:4 Changed on Sep 25, 2012 at 5:42:41 PM by dkocher

  • Component changed from ftp to core
  • Summary changed from App freezes on "open" file to Freezes on "open" file

comment:5 Changed on Sep 25, 2012 at 10:49:47 PM by Kkwan4

the work around works
I can confirm that this is an issue with 10.8.2
I have another machine still on 10.8.1 not having this issue.

comment:6 Changed on Sep 26, 2012 at 8:33:24 AM by dkocher

#6885 closed as duplicate.

comment:7 Changed on Sep 26, 2012 at 4:57:03 PM by dkocher

I cannot replicate this issue. Can you also test with the latest snapshot build available. Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:8 Changed on Sep 26, 2012 at 5:38:18 PM by Kkwan4

I tested with the latest 4.2.2 (9757) snapshot build and it provided the same effect, strangely no logs under console.app.

This was how I tested

  • I re-enabled odb via
    defaults write ch.sudo.cyberduck editor.odb.enable true
    
  • configured Cyberduck with the lastest snapshot build
  • updated to the latest snapshot build
  • installed and restarted
  • opened up sftp connection and highlight a file to edit
  • click the text wrangler edit icon
  • cyberduck causes text wrangler to startup and launch
  • cyberduck will display spinning beach ball for about 5-10minutes, then return to normal idle state


no logs found under console.app other than these update requests

12/9/26 10:10:22.498 AM Cyberduck[8947]: Sparkle Error: An error occurred in retrieving update information. Please try again later.
12/9/26 10:10:22.498 AM Cyberduck[8947]: Sparkle Error (continued): The operation couldn’t be completed. (NSURLErrorDomain error -1100.)

These logs were generated before I changed the setting to update with latest snapshot build

When I disable odb via

defaults write ch.sudo.cyberduck editor.odb.enable false

I'm able to click the text wrangler edit icon and it appears to be working again where I can edit/save and it will update the remote file

I hope this helps.

comment:9 Changed on Sep 26, 2012 at 5:46:08 PM by dkocher

  • Status changed from new to assigned

comment:10 in reply to: ↑ 1 Changed on Sep 27, 2012 at 6:06:36 AM by Brett Francis

  • Cc Brett Francis added

I have effectively the same issue but when using CyberDuck 4.2.1, BBEdit 10.1.2 and Mac OS X 10.8.2

The moment I try to "Edit With..." BBEdit I get a spinning beach-ball of death and according to the Force Quit menu CyberDuck immediately becomes an "Application Not Responding".

Replying to Kkwan4:

my environment is : OS X 10.8.2
cyberduck version : 4.2.1
text wrangler version : 4.0.1
smultron version : 3.5

comment:11 Changed on Oct 3, 2012 at 11:45:33 AM by DanielJLewis

It looks like this is being worked on, but I'll also add that this happens with Fraise.

OS X 10.8.2 Cyberduck 4.2.2 (9796)

comment:12 Changed on Oct 4, 2012 at 9:44:13 AM by dkocher

#6877 closed as duplicate.

comment:13 Changed on Oct 4, 2012 at 7:11:05 PM by dkocher

#6897 closed as duplicate with hang report attached.

  Thread 0xa162f    priority 46        
15 Java_ch_cyberduck_ui_cocoa_odb_ODBEditor_edit + 223 (libODBEdit.dylib) [0x32f786af]
  15 -[ODBEditor editFile:options:forClient:context:] + 70 (libODBEdit.dylib) [0x32f78ade]
    15 -[ODBEditor(Private) _editFile:isEditingString:options:forClient:context:] + 496 (libODBEdit.dylib) [0x32f78fc4]
      15 AESend + 87 (HIToolbox) [0x96fa0949]
        15 aeSend + 218 (AE) [0x97fff577]
          15 AESendMessage + 5872 (AE) [0x97fd9dc3]
            15 CFRunLoopRunInMode + 123 (CoreFoundation) [0x97b824ab]
              15 CFRunLoopRunSpecific + 378 (CoreFoundation) [0x97b8263a]
                15 __CFRunLoopRun + 1247 (CoreFoundation) [0x97b82f7f]
                  15 __CFRunLoopServiceMachPort + 185 (CoreFoundation) [0x97b7d599]
                    15 mach_msg_trap + 10 (libsystem_kernel.dylib) [0x90ced7d2]
                     *15 ipc_mqueue_receive_continue + 0 (mach_kernel) [0xffffff8000213030]


Process:         appleeventsd [63]
Path:            /System/Library/CoreServices/appleeventsd
Architecture:    x86_64
Parent:          launchd [1]
UID:             71
Sudden Term:     Dirty (allows idle exit)
Task size:       904 pages

  Thread 0x310      DispatchQueue 2          priority 33        
  15 _dispatch_mgr_thread + 54 (libdispatch.dylib) [0x7fff955be9ee]
    15 kevent + 10 (libsystem_kernel.dylib) [0x7fff8ef49d16]
     *15 ??? (mach_kernel + 3471600) [0xffffff800054f8f0]

  Thread 0x311      DispatchQueue 7          priority 31        
  15 _dispatch_sig_thread + 45 (libdispatch.dylib) [0x7fff955bbd85]
    15 __sigsuspend_nocancel + 10 (libsystem_kernel.dylib) [0x7fff8ef49566]
     *15 ??? (mach_kernel + 3581216) [0xffffff800056a520]

  Binary Images:
         0x1072da000 -        0x1072dafff  appleeventsd <4617FC4D-4C6C-3B62-9E64-08F9C99ABEEF> /System/Library/CoreServices/appleeventsd
      0x7fff8ef37000 -     0x7fff8ef52ff7  libsystem_kernel.dylib <C0535565-35D1-31A7-A744-63D9F10F12A4> /usr/lib/system/libsystem_kernel.dylib
      0x7fff955ba000 -     0x7fff955cfff7  libdispatch.dylib <D26996BF-FC57-39EB-8829-F63585561E09> /usr/lib/system/libdispatch.dylib
 *0xffffff8000200000 - 0xffffff800074033c  mach_kernel <69A5853F-375A-3EF4-9247-478FD0247333> /mach_kernel

comment:14 follow-up: Changed on Oct 4, 2012 at 7:12:57 PM by dkocher

It is either appleeventsd that or the editor receiving the event that is blocking.

comment:15 in reply to: ↑ 14 Changed on Oct 4, 2012 at 7:16:26 PM by dkocher

Replying to dkocher:

It is either appleeventsd that or the editor receiving the event that is blocking.

We are using the default timeout in AESend which is defined as

  kAEDefaultTimeout             = -1,   /* timeout value determined by AEM */

We should change that to a sensible default.

comment:16 Changed on Oct 4, 2012 at 7:19:04 PM by dkocher

A third party filed rdar://12424662 describing the exact same issue. Looks like this bug was introduced in 10.8.2.

comment:17 Changed on Oct 4, 2012 at 7:21:59 PM by dkocher

Timeout set in r9848.

comment:18 follow-up: Changed on Oct 5, 2012 at 2:32:37 AM by Blomberg Samuel

Can confirm that editing a file with Espresso is also causing Cyberduck to hang.

defaults write ch.sudo.cyberduck editor.odb.enable true

This workaround alleviates the hang, but I would also like to know what the downsides are (if any) of using said workaround until an official fix is implemented.

  • OS: Mac OSX 10.8.2
  • Cyberduck: 4.2.1

comment:19 in reply to: ↑ 18 Changed on Oct 5, 2012 at 1:41:57 PM by dkocher

Replying to Blomberg Samuel:

Can confirm that editing a file with Espresso is also causing Cyberduck to hang.

defaults write ch.sudo.cyberduck editor.odb.enable true

This workaround alleviates the hang, but I would also like to know what the downsides are (if any) of using said workaround until an official fix is implemented.

The only downside should be that temporary files are not moved to the trash after closing the editor.

comment:20 Changed on Oct 7, 2012 at 3:52:45 PM by dkocher

#6874 closed as duplicate.

comment:21 Changed on Oct 15, 2012 at 7:13:00 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Disabled ODB in r10265.

comment:22 Changed on Nov 4, 2012 at 8:05:48 PM by dkocher

  • Summary changed from Freezes on "open" file to Application hangs editing file in external editor

comment:23 Changed on Nov 7, 2012 at 5:32:53 PM by dkocher

#6948 closed as duplicate.

comment:24 Changed on Nov 8, 2012 at 10:01:19 PM by dkocher

#6954, #6951 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software