Cyberduck Mountain Duck CLI

#6902 closed enhancement (fixed)

Multiple Region Support

Reported by: Arcanelinux Owned by: dkocher
Priority: normal Milestone: 4.4
Component: cloudfiles Version: 4.2.1
Severity: normal Keywords: cloudfiles, rackspace, multiple_regions
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description

Rackspace Cloud Files now has multiple region support for US accounts, (DFW and ORD). Currently when using Cyberduck it defaults to the DFW region. Presently there is not a way to access the ORD region via Cyberduck. Can an option be added to select the region?

Change History (12)

comment:1 Changed on Oct 7, 2012 at 3:52:26 PM by Arcanelinux

  • Type changed from defect to enhancement

comment:2 Changed on Oct 7, 2012 at 4:08:53 PM by dkocher

  • Milestone set to 4.3
  • Priority changed from high to normal
  • Severity changed from major to normal
  • Status changed from new to assigned

comment:3 Changed on Dec 4, 2012 at 6:35:31 PM by dkocher

  • Summary changed from Cloud Files Multiple Region Support to Multiple Region Support

comment:4 follow-up: Changed on Feb 4, 2013 at 8:44:44 PM by spight

Hello,

Would it be possible to upwardly re-prioritize this particular issue? Cloud Files support is losing the ability to change the v1.0 default endpoint at all, and customers are suffering because of it. We're also rolling out new regions, which will further complicate this issue in the near future. If I can help in any way with the login process for v2.0 algorithmically or in terms of the API, please let me know.

Also I want to point out that this shouldn't defaulting to DFW specifically, but to the customer's default region (in v1.0) which is set on account creation. Since the current default region is DFW, most people do experience the issue as stated in the description, but some have the opposite issue.

Best Regards,

Kenneth Kirkpatrick

Rackspace Cloud

Last edited on Feb 4, 2013 at 8:45:31 PM by spight (previous) (diff)

comment:5 in reply to: ↑ 4 Changed on Feb 4, 2013 at 9:03:44 PM by dkocher

Replying to spight:

Hello,

Would it be possible to upwardly re-prioritize this particular issue? Cloud Files support is losing the ability to change the v1.0 default endpoint at all, and customers are suffering because of it. We're also rolling out new regions, which will further complicate this issue in the near future. If I can help in any way with the login process for v2.0 algorithmically or in terms of the API, please let me know.

Also I want to point out that this shouldn't defaulting to DFW specifically, but to the customer's default region (in v1.0) which is set on account creation. Since the current default region is DFW, most people do experience the issue as stated in the description, but some have the opposite issue.

Best Regards,

Kenneth Kirkpatrick

Rackspace Cloud

To help speed things up I would appreciate if

comment:6 Changed on Feb 4, 2013 at 9:20:53 PM by dkocher

Relevant changeset.

comment:7 Changed on Feb 5, 2013 at 12:06:55 AM by spight

Thanks for your quick response. I'll look into the java-cloudfiles maintainer.

Last edited on Feb 5, 2013 at 10:12:34 AM by spight (previous) (diff)

comment:8 Changed on Feb 11, 2013 at 5:37:34 AM by spight

Well looks like we're finally getting access to change v1 regions again. You can lower than priority on this again if you wish.

Last edited on Mar 20, 2013 at 10:51:01 PM by spight (previous) (diff)

comment:9 follow-up: Changed on Apr 25, 2013 at 7:50:59 PM by james robinson

I can confirm this is not working on Windows with the latest version 4.3 released today. I would also like to see this added. Is there a workaround in the interim?

comment:10 in reply to: ↑ 9 Changed on Apr 26, 2013 at 5:15:01 PM by dkocher

Replying to james robinson:

I can confirm this is not working on Windows with the latest version 4.3 released today. I would also like to see this added. Is there a workaround in the interim?

There is no known workaround other than asking Rackspace to change your default region.

comment:11 Changed on May 25, 2013 at 3:06:27 PM by dkocher

We have pushed support for regions with v1.1 authentication to https://github.com/dkocher/java-cloudfiles.

comment:12 Changed on Jun 4, 2013 at 7:07:04 AM by dkocher

  • Milestone changed from 4.4 to 4.3.2
  • Resolution set to fixed
  • Status changed from assigned to closed

In r11080.

Note: See TracTickets for help on using tickets.
swiss made software