Cyberduck Mountain Duck CLI

#6934 closed defect (fixed)

Duplicate file or directory causes hang

Reported by: Trapbox Owned by: dkocher
Priority: normal Milestone: 4.3
Component: sftp Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description

Attempting to duplicate a file or folder seems to cause Cyberduck to lock up.

How I can reproduce this

  1. log into host via SFTP
  2. attempt to duplicate either a directory or file

Results

  • cyberduck will become unresponsive with spinning beach ball
  • cyberduck appear in the list of Not Responding apps available for Force Quit
  • cyberduck listed as not responding within 15 seconds of selecting to duplicate

Noticed different result for a a dreamhost.com account and non-dreamhost account I was able to access

Results (Dreamhost)

  • connect via SFTP -> duplicate causes lockup
  • connect via FTP -> duplicate does not cause lockup

Results (non-Dreamhost)

  • connect via SFTP -> duplicate does not cause lockup
  • connect via FTP -> duplicate does not cause lockup

I checked only against the two accounts on the two different hosts. Not sure if the issue is with SFTP and duplicate is limited to Dreamhost servers or if it's reproducible elsewhere.

Change History (9)

comment:1 Changed on Nov 1, 2012 at 3:20:25 PM by dkocher

Thanks for your bug report. Can you reproduce this issue with the latest snapshot build available?

comment:2 Changed on Nov 1, 2012 at 3:20:36 PM by dkocher

  • Milestone set to 4.2.2
  • Status changed from new to assigned

comment:3 Changed on Nov 1, 2012 at 9:11:04 PM by Trapbox

Will try reproducing with snapshot build. Switched my updates to snapshot and will report back with what happens after the I have the new build installed.

comment:4 Changed on Nov 1, 2012 at 9:22:39 PM by Trapbox

Looks like it is reproducible with the snapshot I pulled Version 4.2.2 (10576)

Results (Dreamhost)

  • :-( connect via SFTP -> duplicate causes lockup
  • :-) connect via FTP -> duplicate does not cause lockup

Results (non-Dreamhost)

  • :-) connect via SFTP -> duplicate does not cause lockup
  • :-) connect via FTP -> duplicate does not cause lockup

Following is some info from the generated problem report...

Date/Time:       2012-11-01 14:14:21 -0700
OS Version:      10.8.2 (Build 12C60)
Architecture:    x86_64
Report Version:  11

Command:         Cyberduck
Path:            /Applications/Cyberduck.app/Contents/MacOS/Cyberduck
Version:         4.2.2 (10576)
Parent:          launchd [946]

PID:             72382
Event:           hang
Duration:        1.59s
Steps:           17 (100ms sampling interval)

Hardware model:  MacBookPro5,3
Active cpus:     2
Free pages:      54693 pages (+20111)
Pageins:         1 pages
Pageouts:        0 pages

comment:5 Changed on Nov 24, 2012 at 9:25:19 PM by dkocher

As this is provider specific it is difficult for me to replicate the issue. Is it possible to get temporary access to such an account? (Reply to feedback@cyberduck.ch).

comment:6 Changed on Nov 24, 2012 at 11:13:39 PM by dkocher

  • Summary changed from Duplicate file or directory causes Cyberduck to lock up to Duplicate file or directory causes hang

comment:7 Changed on Nov 26, 2012 at 7:34:35 PM by Trapbox

Test account created and forwarded for trials.

If it helps troubleshooting, the Version I see from ftp status is as follows

	Version: tnftp 20070806

I was able to reproduce the problem with the newly created test account by

  • logging in via SFTP
  • creating a 'test' dir
  • attempting to duplicate the empty 'test' dir
  • cyberduck stops responding
Last edited on Nov 27, 2012 at 9:38:11 AM by dkocher (previous) (diff)

comment:8 Changed on Nov 27, 2012 at 10:38:43 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r10608.

comment:9 Changed on Nov 27, 2012 at 10:48:55 AM by dkocher

Please verify the fix with the latest snapshot build (r10608).

Note: See TracTickets for help on using tickets.
swiss made software