Cyberduck Mountain Duck CLI

#694 closed defect (worksforme)

Error loading class from NIB

Reported by: cedric.ohle@… Owned by: dkocher
Priority: highest Milestone:
Component: core Version: 2.7.3
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

First time i installed cyberduck on my machine it works! But then after a reboot its only starting and then ready, but can do nothing! Every menuitem is greyed out except the update one a no window is appearing! The console is showing this:

Aug 21 01:52:08 Cedrics-PowerBook /Applications/Netzwerk: Internet/Cyberduck.app/Contents/MacOS/Cyberduck: Java is generating its shared archive, version 1.5
2006-08-21 01:52:11.784 Cyberduck[1032] Unknown class `ch.cyberduck.ui.cocoa.CDMainController' in nib file, using `NSObject' instead.
2006-08-21 01:52:11.785 Cyberduck[1032] Could not connect the action donateMenuClicked: to target of class NSObject
2006-08-21 01:52:11.786 Cyberduck[1032] Could not connect the action licenseMenuClicked: to target of class NSObject
2006-08-21 01:52:11.787 Cyberduck[1032] Could not connect the action preferencesMenuClicked: to target of class NSObject
2006-08-21 01:52:11.787 Cyberduck[1032] Could not connect the action feedbackMenuClicked: to target of class NSObject
2006-08-21 01:52:11.788 Cyberduck[1032] Could not connect the action newDownloadMenuClicked: to target of class NSObject
2006-08-21 01:52:11.788 Cyberduck[1032] Could not connect the action newBrowserMenuClicked: to target of class NSObject
2006-08-21 01:52:11.789 Cyberduck[1032] Could not connect the action newBrowserMenuClicked: to target of class NSObject
2006-08-21 01:52:11.790 Cyberduck[1032] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject
2006-08-21 01:52:11.791 Cyberduck[1032] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject
2006-08-21 01:52:11.791 Cyberduck[1032] Could not connect the action helpMenuClicked: to target of class NSObject
2006-08-21 01:52:11.791 Cyberduck[1032] Could not connect the action bugreportMenuClicked: to target of class NSObject
2006-08-21 01:52:11.792 Cyberduck[1032] Could not connect the action aboutMenuClicked: to target of class NSObject

What can i do?

Change History (13)

comment:1 Changed on Aug 21, 2006 at 1:39:48 PM by dkocher

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed

Remove the colon from the folder named 'Netzwerk:Internet'

comment:2 Changed on Aug 21, 2006 at 5:58:40 PM by cedric.ohle@…

But it is a "slash"!

comment:3 Changed on Aug 21, 2006 at 6:00:37 PM by cedric.ohle@…

But removing the symbol works! Thanks, but please fix it!:-)

comment:4 Changed on Sep 3, 2006 at 10:17:55 AM by thelin@…

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I have the same problem but i dont have a folder named Netzwerk/Internet, where should I find it?. How do I know wich folder thats causing this? Is it named diffrently in a Swedish version of Mac OS X?

It's strange that a folder name is allowed to cause this. Sounds more like a bug.

2006-09-03 12:11:03.750 Cyberduck[267] Unknown class ch.cyberduck.ui.cocoa.CDMainController' in nib file, using NSObject' instead. 2006-09-03 12:11:03.750 Cyberduck[267] Could not connect the action donateMenuClicked: to target of class NSObject 2006-09-03 12:11:03.750 Cyberduck[267] Could not connect the action licenseMenuClicked: to target of class NSObject 2006-09-03 12:11:03.750 Cyberduck[267] Could not connect the action preferencesMenuClicked: to target of class NSObject 2006-09-03 12:11:03.750 Cyberduck[267] Could not connect the action feedbackMenuClicked: to target of class NSObject 2006-09-03 12:11:03.750 Cyberduck[267] Could not connect the action newDownloadMenuClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action helpMenuClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action bugreportMenuClicked: to target of class NSObject 2006-09-03 12:11:03.751 Cyberduck[267] Could not connect the action aboutMenuClicked: to target of class NSObject

comment:5 Changed on Sep 3, 2006 at 12:33:45 PM by cedric.ohle@…

Of course you hav not this folder, but the thing is that cyberduck has a problem with special characters anywhere in the path to your cyberduckversion.

comment:6 Changed on Sep 4, 2006 at 9:01:50 PM by thelin@…

But that sounds like a bug to me. And what do you mean with "anywhere in the path to your cyberduckversion"? Cyberduck.app is located in /Applications

It strange because it has been working great before and it works fine on my other computer.

comment:7 Changed on Feb 13, 2007 at 12:06:45 PM by schwitzkroko

  • Version changed from 2.6.1 to 2.7.2

i experienced this too. got build 2838 by update feature, then reinstalled same build as downloaded dmg - its the same, and looks like this:

*snip* 2007-02-13 12:59:46.017 Cyberduck[361] Unknown class ch.cyberduck.ui.cocoa.delegate.EditMenuDelegate' in nib file, using NSObject' instead. 2007-02-13 12:59:46.018 Cyberduck[361] Unknown class ch.cyberduck.ui.cocoa.delegate.BookmarkMenuDelegate' in nib file, using NSObject' instead. 2007-02-13 12:59:46.018 Cyberduck[361] Unknown class ch.cyberduck.ui.cocoa.delegate.RendezvousMenuDelegate' in nib file, using NSObject' instead. 2007-02-13 12:59:46.019 Cyberduck[361] Unknown class ch.cyberduck.ui.cocoa.CDMainController' in nib file, using NSObject' instead. 2007-02-13 12:59:46.020 Cyberduck[361] Unknown class ch.cyberduck.ui.cocoa.delegate.HistoryMenuDelegate' in nib file, using NSObject' instead. 2007-02-13 12:59:46.020 Cyberduck[361] Could not connect the action donateMenuClicked: to target of class NSObject 2007-02-13 12:59:46.020 Cyberduck[361] Could not connect the action licenseMenuClicked: to target of class NSObject 2007-02-13 12:59:46.020 Cyberduck[361] Could not connect the action preferencesMenuClicked: to target of class NSObject 2007-02-13 12:59:46.020 Cyberduck[361] Could not connect the action feedbackMenuClicked: to target of class NSObject 2007-02-13 12:59:46.020 Cyberduck[361] Could not connect the action newDownloadMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action helpMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action bugreportMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action aboutMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action historyMenuClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action downloadBookmarksFromDotMacClicked: to target of class NSObject 2007-02-13 12:59:46.021 Cyberduck[361] Could not connect the action uploadBookmarksToDotMacClicked: to target of class NSObject *snip*

my version actually is 2.7.3 build 2838, there is no 2.7.3 in version dropdown menue!

  • thanks! would love to use cyberduck again!

gruesse j

comment:8 Changed on Feb 13, 2007 at 5:54:52 PM by schwitzkroko

  • Version changed from 2.7.2 to 2.7.3

killed my ~/Library/Preferences/ch.sudo.cyberduck.plist and it works fine. imo newer version were not compatible with existing plist. should be regarded especially when advertising and distributing updates.

comment:9 Changed on Mar 25, 2007 at 2:27:47 PM by dkocher

  • Summary changed from Every Menuitem greyed out to Error loading class from NIB

This failure is not only caused by colons in the pathname but also for other unknown reason(s). See also http://forums.cocoaforge.com/viewtopic.php?t=12644

No workaround is known yet.

comment:10 Changed on Apr 7, 2007 at 8:24:24 AM by Digitalsabre

On my machine, it seems to be a Java Virtual Machine error. See, the problem with this code is that I'm not running a PPC MacBook:

Java for ppc cannot run in this configuration. Please consult documentation. -[NSJavaVirtualMachine initWithClassPath:] cannot instantiate a Java virtual machine 2007-04-07 02:51:31.455 Cyberduck[6647] Unknown class ch.cyberduck.ui.cocoa.CDMainController' in nib file, using NSObject' instead. 2007-04-07 02:51:31.460 Cyberduck[6647] Could not connect the action donateMenuClicked: to target of class NSObject 2007-04-07 02:51:31.460 Cyberduck[6647] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2007-04-07 02:51:31.462 Cyberduck[6647] Could not connect the action licenseMenuClicked: to target of class NSObject 2007-04-07 02:51:31.462 Cyberduck[6647] Could not connect the action websiteMenuClicked: to target of class NSObject 2007-04-07 02:51:31.463 Cyberduck[6647] Could not connect the action preferencesMenuClicked: to target of class NSObject 2007-04-07 02:51:31.464 Cyberduck[6647] Could not connect the action feedbackMenuClicked: to target of class NSObject 2007-04-07 02:51:31.465 Cyberduck[6647] Could not connect the action updateMenuClicked: to target of class NSObject Java for ppc cannot run in this configuration. Please consult documentation. -[NSJavaVirtualMachine initWithClassPath:] cannot instantiate a Java virtual machine 2007-04-07 03:04:52.613 Cyberduck[6652] Unknown class ch.cyberduck.ui.cocoa.CDMainController' in nib file, using NSObject' instead. 2007-04-07 03:04:52.649 Cyberduck[6652] Could not connect the action donateMenuClicked: to target of class NSObject 2007-04-07 03:04:52.650 Cyberduck[6652] Could not connect the action newBrowserMenuClicked: to target of class NSObject 2007-04-07 03:04:52.652 Cyberduck[6652] Could not connect the action licenseMenuClicked: to target of class NSObject 2007-04-07 03:04:52.653 Cyberduck[6652] Could not connect the action websiteMenuClicked: to target of class NSObject 2007-04-07 03:04:52.654 Cyberduck[6652] Could not connect the action preferencesMenuClicked: to target of class NSObject 2007-04-07 03:04:52.655 Cyberduck[6652] Could not connect the action feedbackMenuClicked: to target of class NSObject 2007-04-07 03:04:52.677 Cyberduck[6652] Could not connect the action updateMenuClicked: to target of class NSObject

You can see that there are two instances of failed execution here, with the same resulting errors. I am also running a Mac OS X 10.4.9 on a Core 2 Duo low end late 2006 white Macbook, and this is ocurring with CyberDuck 2.7.3. Furthermore, after deleting the preference file, the menus no function work at all, whereas they worked before deleting the preference plist file from ~/Library/Preferences

Hope this helps.

comment:11 Changed on May 14, 2007 at 5:25:03 PM by mdonoughe

After linking /System/Library/Frameworks/JavaVM.framework/Versions/Current/JavaVM (was missing) to /System/Library/Frameworks/JavaVM.framework/Versions/A/JavaVM I can launch Cyberduck from the terminal by typing /Applications/Cyberduck.app/Contents/MacOS/Cyberduck. Double clicking Cyberduck.app fails the same way as before.

comment:12 Changed on May 18, 2007 at 10:09:48 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Manually changing symbolic links in /JavaVM.framework/Versions/ is officially not supported by Apple and will possibly break any application depending on the Java Framework. Please refer to kbase.info.apple.com and reinstall Java.

comment:13 Changed on May 27, 2007 at 10:42:29 AM by dkocher

Also see the duplicate at #187.

Note: See TracTickets for help on using tickets.
swiss made software