Cyberduck Mountain Duck CLI

#7003 closed defect (worksforme)

App Store validation failure on application launch

Reported by: Mdadki Owned by:
Priority: normal Milestone:
Component: core Version: 4.2.1
Severity: normal Keywords: damaged
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description

Hello Cyberduck Devs,

I've used Cyberduck for years and loved it, but have had issues when downloading through the Apple App Store. On my laptop (as updated as possible MacBookPro), I've used the version downloaded from your website without issue. On my work computer, I figured it may be easier to streamline everything, so I downloaded through the App Store. Again, no issue, works great. Back to my laptop, I removed the app (grepping ~/ for remnants as well), and downloaded from the App Store. Upon trying to open the app, I get a small error window saying "“Cyberduck.app” is damaged and can’t be opened. Delete “Cyberduck.app” and download it again from the App Store." I've tried this several times, but to no avail. All other apps from the App Store have installed and worked just fine.

Any feedback or suggestions would be very much appreciated, Michael Adkins

Change History (7)

comment:1 Changed on Dec 16, 2012 at 10:19:46 PM by dkocher

  • Summary changed from Cyberduck is damaged upon download to App Store validation failure on application launch

comment:2 Changed on Dec 16, 2012 at 10:30:29 PM by dkocher

Found the following reference to the same issue:

comment:3 Changed on Dec 16, 2012 at 10:31:42 PM by dkocher

It would also help if you could verify the signature of the downloaded application by opening a Terminal.app window and paste

codesign -dvvv /Applications/Cyberduck.app

comment:4 Changed on Dec 16, 2012 at 10:35:15 PM by dkocher

Also make sure you have no "cleaning" application installed that for example removes some localizations from the application to save disk space. It will break the signature of the downloaded application.

comment:5 Changed on Dec 16, 2012 at 10:35:30 PM by dkocher

This was previously unresolved in #6018.

comment:6 Changed on Dec 17, 2012 at 10:24:24 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:7 Changed on Nov 12, 2013 at 8:44:53 AM by dkocher

We have a new issue that shows the same symptoms which was fixed as reported in #7557. Users can request a donation key at feedback@cyberduck.ch who want to switch to the free version available from the website. The 4.4.1 update is still pending expedited review by Apple for the Mac App Store.

Note: See TracTickets for help on using tickets.