Cyberduck Mountain Duck CLI

#7009 closed defect (duplicate)

Cloud Files deletion on move bug

Reported by: jspringman Owned by: dkocher
Priority: highest Milestone: 4.3
Component: cloudfiles Version: 4.2.1
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description

Steps to reproduce the bug are as follows:

  1. Log into Cloud Files account via Cyberduck.
  2. Create two containers, such as "test1" and "test2."
  3. Upload a directory containing one or more files to the "test1" container.
  4. Once the directory has been uploaded to the "test1" container, drag it to the "test2" container.
  5. The directory is deleted. It does not appear in the "test2" container.

I lost 144 user-submitted photos this way, and since Rackspace does not back up user containers, they are irretrievable. Moving individual files from one container to another works fine, but moving a directory simply results in the deletion of that directory every time I've tried.

Change History (1)

comment:1 Changed on Dec 21, 2012 at 8:03:07 AM by dkocher

  • Milestone set to 4.2.2
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for reporting this issue. Duplicate for #6442. Please update to the latest beta build available.

Note: See TracTickets for help on using tickets.