Cyberduck Mountain Duck CLI

#7034 closed defect (worksforme)

Issue on Renaming folder with subfolder

Reported by: yanr Owned by: dkocher
Priority: high Milestone: 4.3
Component: s3 Version: 4.2.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by dkocher)

Steps to reproduce

  1. prepare a folder with subfolder on local disk, see below
    test/-
          - a.jpg
          - dir1/
            - b.jpg
  1. upload folder 'test' to a S3 bucket
  1. rename folder 'test' to 'test11'
  1. the result displayed in cyberduck is below: (after refresh)
    test11/
       - a.jpg
       - dir1/
          - b.jpg
    test/
       - dir1/

Change History (4)

comment:1 Changed on Jan 6, 2013 at 8:45:36 AM by dkocher

  • Status changed from new to assigned

comment:2 Changed on Apr 4, 2013 at 3:34:43 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Apr 4, 2013 at 3:40:03 PM by dkocher

This implies that placeholder directories are not deleted after renaming child keys.

comment:4 Changed on Apr 4, 2013 at 3:53:23 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

I cannot reproduce this issue with the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software