Cyberduck Mountain Duck CLI

#7047 closed defect (duplicate)

Program Startup Close to a Minute on New Retina MacBook Pro

Reported by: gregspiral Owned by:
Priority: normal Milestone:
Component: core Version: Nightly Build
Severity: normal Keywords: slow startup
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description

I just noticed that it takes nearly a minute for Cyberduck to load now on my system. I actually did force quit a few times thinking that the program was frozen. Then I let it go and after about a minute it loaded. I can't figure out why the delay. I've used Cyberduck on two machines now and my current machine has an SSD and core i7 and 16 GB of RAM. Cyberduck was previously and should no be no challenge for this machine.

I deleted the prefs, that didn't help. I deleted the app and re-installed via AppStore (my current version is through that). Still no luck. Ran Disk Warrior and Permission Repair. Still no luck. Super slow load times. I can't think of anything that changed in my machine that would precipitate this. I'm figuring it must be a bug in the duck. A

I'd appreciate any help.

Thanks, Greg

Change History (6)

comment:1 Changed on Jan 14, 2013 at 9:23:58 AM by dkocher

Can you reproduce this issue with the latest beta build available?

comment:2 Changed on Jan 14, 2013 at 6:44:23 PM by gregspiral

Yes, I have the same problem with 10741 I got out the timer just to see. The app store install that I have takes 45.8 seconds to load. The app I'm running from my downloads folder takes 47.3 seconds to load.

I only have one host server. I use BlueHost. I've got a 5 websites and so have 5 ftp accounts; but I'm a pretty simple user. I make/update webpages and ftp the files. Somewhere around 12/27 I updated several of my sites and Cyberduck had no issues. Since then I hadn't tried to update anything until last week. I've been running FileZilla since last Friday just as an alternative.

Are the mac Java securities affecting this? I'd expect a number of people to have issues if this were the case.

comment:3 Changed on Jan 21, 2013 at 7:20:49 PM by mr_hedgehog

  • Keywords slow startup added
  • Version changed from 4.2.1 to Nightly Build

I figure I'd add to this, since my issue seems similar.

I haven't clocked it, but Cyberduck takes 4-6 minutes to startup on my Mac Pro, running 10.7.5. It started with version 4.2.1 IRCC, and it's persisted with 4.2.2 (10741). Once started, the downloads tend to get stuck after only a few seconds. When quitting and then restarting, the behaviour is the same.

On my MBA running 10.8.2 I'm not having any issues, but I can't tell what's different in any dependencies between the computers though. (OP mentions Java as a possible culprit) Only Cyberduck displays this behaviour.

I can't recall if there was a software update on the Mac Pro around the time the problems started, and I've tried to uninstall any odd background processes, with no change. Permissions repaired without any improvement. Please advise

comment:4 Changed on Jan 29, 2013 at 3:48:42 PM by dkocher

This might be a duplicate of #5971. Do you have Sophos Anit-Virus installed?

comment:5 Changed on Jan 29, 2013 at 3:53:52 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

comment:6 Changed on Jan 29, 2013 at 8:14:58 PM by gregspiral

I do not have Sophos Anti-Virus installed. Honestly, my best solution was to install FileZilla. I'm simply uninstalling the duck. Cute as it is, I need it to function and after 3 weeks there are still no useful solutions. Good luck.

Note: See TracTickets for help on using tickets.
swiss made software