Cyberduck Mountain Duck CLI

#7181 closed defect (worksforme)

Drag and Drop fails to work in OS X 10.6.8

Reported by: kim bailey Owned by: Kim Bailey
Priority: highest Milestone:
Component: core Version: 4.3
Severity: normal Keywords: Drag and drop
Cc: Architecture: Intel
Platform: Mac OS X 10.6

Description (last modified by dkocher)

After searching the web for solutions to fix the problem, uploading the new java script, removing any traces of any cisco product, reinstalling the operating system, repairing permissions twice and restarting, Cyberduck still does not do drag and drop to an open window along with other issues.

Cyberduck 4.3 running Mac OS X 10.6.8 There are actually a number of issues, they are as follows

  1. Drag and Drop does not work
  2. Double click to download does not work
  3. On every launch Cyberduck asks for permission to access keychain
  4. Transfer window after cleaning will reappear on next launch.

Obviously there is something more going on than drag and drop failure.

The last two applications installed and removed were the new Eudora OSE which has been unistalled and Cisco WebEx which has been unistalled.

Change History (13)

comment:1 Changed on Apr 27, 2013 at 7:31:23 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Apr 30, 2013 at 2:00:49 PM by EduardoPestanaM

I have *exactly* the same problem with the same issues

The only difference is that, in my case, it appeared 3hours ago after I updated the firmware of my Belkin F5D8236-4 router.

Right now I am at my office in the University. As soon as I get home I will try connecting the computer directly to the adsl modem to see if the problem continues

All the best, Eduardo Pestana

comment:3 Changed on Apr 30, 2013 at 2:04:55 PM by dkocher

Please be more specific on what is not working and the exact steps to follow to reproduce the issue.

comment:4 Changed on Apr 30, 2013 at 8:02:00 PM by EduardoPestanaM

Just now I tried connecting the computer (MacBookPro, Intel Core 2 duo, OS X 10.6.8) directoy to the adsl modem and still I cannot do drag and drop to upload. I can use sftp at the terminal and uploads work perfect (not very convenient...agghhh)

At the uninversity office (iMac intel Core Duo 2Ghz, OSX10.6.8) cyberduck works perfectly. Could you please help me? All the best, Eduardo Pestana

comment:5 Changed on Apr 30, 2013 at 8:16:42 PM by EduardoPestanaM

Also, uploads fail using the dropdown Action menu

comment:6 Changed on Apr 30, 2013 at 8:29:50 PM by EduardoPestanaM

Either using drag and drop or the Action dropdown menu the transfers window reports "Upload complete 0 B of 0 B"

comment:7 Changed on May 1, 2013 at 2:14:34 AM by EduardoPestanaM

I found a workaround: You select (highlight blue) the item that failed to upload in the transfers window, then you hit the reload button on top of the transfers window and every thing is ok.

comment:8 Changed on May 1, 2013 at 2:30:05 AM by EduardoPestanaM

I tried another laptop (MacBookPro Intel Core 2 Duo, 32bit, 10.6.8) with cyberduck 4.3.1 and everything is fine. The laptop with the problem (MacBookPro, Intel Core 2 duo, OS X 10.6.8) runs at 2.88GHz and in 64bit mode. This was tested using the same belkin router, so it seems that the problem is not related to the router.

comment:9 Changed on May 1, 2013 at 7:17:47 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:10 follow-up: Changed on May 1, 2013 at 7:18:52 PM by dkocher

Please try to remove the list of saved items in the transfer list by moving the file ~/Library/Application Support/Cyberduck/Queue.plist to the Trash.

comment:11 in reply to: ↑ 10 Changed on May 1, 2013 at 7:42:35 PM by EduardoPestanaM

Replying to dkocher:

Please try to remove the list of saved items in the transfer list by moving the file ~/Library/Application Support/Cyberduck/Queue.plist to the Trash.

It worked! Everything is fine. Drag and drop now works fine! Thank you....

comment:12 Changed on May 1, 2013 at 8:41:03 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

The issue was possibly caused by a Queue.plist file with invalid entries from a prior snapshot build installed.

comment:13 Changed on May 2, 2013 at 4:15:19 PM by dkocher

Fix in r10994.

Note: See TracTickets for help on using tickets.
swiss made software