Cyberduck Mountain Duck CLI

#7243 closed defect (worksforme)

501 Not Implemented error for upload

Reported by: Xarno Owned by: yla
Priority: normal Milestone: 4.4
Component: s3 Version: 4.3.1
Severity: major Keywords:
Cc: Architecture:
Platform: Windows 7

Description

Os: Windows 7 Ultimate
Cyberduck Version: 4.3.1
Tested on 2 machines, only reproduceable on one.

What happens: Drag and Drop or File select and upload with a file on a network share throw a not implemented error. It is not dependend on a file or a file or folder name. Somehow it is depedend which „view“ (see attached image) for networkshares is opened.

The File Transfer Window show 2 identical lines for the „view“ on top of the image and the „view“ on bottom of the image. BUT for the top „view“ the transport fails with the „Not Implemented“ message.

See attached Logfile for the logging console of Cyberduck and the content of the errormessage.

Attachments (2)

cyberduck bug.png (170.3 KB) - added by Xarno on May 13, 2013 at 2:29:46 PM.
different „Views” of Networkshares, 1 of 3 does not work
cyberduck bug.txt (1.5 KB) - added by Xarno on May 13, 2013 at 2:33:26 PM.
Logging output and content of error message

Download all attachments as: .zip

Change History (7)

Changed on May 13, 2013 at 2:29:46 PM by Xarno

different „Views” of Networkshares, 1 of 3 does not work

Changed on May 13, 2013 at 2:33:26 PM by Xarno

Logging output and content of error message

comment:1 Changed on May 13, 2013 at 2:48:19 PM by dkocher

  • Component changed from core to s3
  • Owner set to yla

comment:2 Changed on Jul 31, 2013 at 7:30:26 PM by dkocher

  • Milestone set to 4.4

comment:3 Changed on Jul 31, 2013 at 7:30:55 PM by dkocher

  • Summary changed from Upload to Amazon S3 broken from some! Networkpaths to 501 Not Implemented error for upload

comment:4 Changed on Sep 18, 2013 at 5:09:51 PM by dkocher

Transfer-Encoding: chunked is not supported. The PUT operation must include a Content-Length header

An invalid request is sent because the size of the file is not known.

comment:5 Changed on Sep 19, 2013 at 9:43:18 AM by yla

  • Resolution set to worksforme
  • Status changed from new to closed

Tried to replicate this issue on Windows 7 and 8 but was not able to. To test I've changed the location of the Desktop folder to a network share. Feel free to reopen the ticket if you have even more information why it works on one machine but not on the second one.

Note: See TracTickets for help on using tickets.
swiss made software