Cyberduck Mountain Duck CLI

#7260 closed defect (worksforme)

Exception - Keine Neue Verbindung möglich

Reported by: chk0 Owned by:
Priority: highest Milestone:
Component: core Version: 4.3.1
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description (last modified by dkocher)

Ich kann keine neue Verbindung aufbauen. Stürzt immer ab. Dieser Fehler entdeckt:

17.05.13 19:55:39.903 Cyberduck[408]: [main] ERROR org.rococoa.callback - Exception calling method for selector tableRowDoubleClicked:

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:156)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.GeneratedMethodAccessor15.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:449)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:479)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:334)
	at com.sun.jna.Function.invoke(Function.java:278)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:232)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:165)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
	at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
	at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.jets3t.service.Jets3tProperties
	at ch.cyberduck.core.s3.S3Session.<init>(S3Session.java:273)
	at ch.cyberduck.core.SessionFactory$1$4.create(SessionFactory.java:77)
	at ch.cyberduck.core.SessionFactory.createSession(SessionFactory.java:108)
	at ch.cyberduck.ui.cocoa.BrowserController.init(BrowserController.java:3546)
	at ch.cyberduck.ui.cocoa.BrowserController.access$2700(BrowserController.java:98)
	at ch.cyberduck.ui.cocoa.BrowserController$31.run(BrowserController.java:3659)
	at ch.cyberduck.ui.cocoa.BrowserController.unmount(BrowserController.java:3762)
	at ch.cyberduck.ui.cocoa.BrowserController.unmount(BrowserController.java:3714)
	at ch.cyberduck.ui.cocoa.BrowserController.mount(BrowserController.java:3654)
	at ch.cyberduck.ui.cocoa.BrowserController.connectBookmarkButtonClicked(BrowserController.java:1787)
	at ch.cyberduck.ui.cocoa.BrowserController$8.tableRowDoubleClicked(BrowserController.java:1510)
	... 32 more

Change History (3)

comment:1 Changed on May 20, 2013 at 8:55:14 PM by dkocher

  • Description modified (diff)

comment:2 Changed on May 20, 2013 at 8:58:30 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Looks like there is missing a resource in the application bundle or there is a conflict with a system wide installed library. Please try to

  • Download a new copy of Cyberduck
  • Remove any libraries in ~/Library/Java/Extensions and /Library/Java/Extensions.

comment:3 Changed on Mar 4, 2015 at 12:50:42 PM by dkocher

Fixed in r17096 with setting the extension directories to only include lib/ext from the bundled runtime.

Note: See TracTickets for help on using tickets.
swiss made software