Cyberduck Mountain Duck CLI

#7299 closed defect (worksforme)

Renaming a Pesudo-Directory in Cloud Files Deletes Contents

Reported by: spight Owned by: dkocher
Priority: high Milestone: 4.4
Component: cloudfiles Version: 4.3.1
Severity: normal Keywords: rename
Cc: Architecture:
Platform: Windows 7

Description (last modified by dkocher)

Hello,

We've found under a few situations that trying to rename a pseudo-folder will result in deleting the folder object and all of the objects listed as children thereof.

To reproduce:

  • Create new container
  • Create pseudo-directory in this container
  • Create an object within this pesudo-directory
  • Rename the pseudo-directory

Expected result:

  • 1 - The object you're attempting to rename is removed from Cloud Files
  • 2- All subobjects of the pseudo-directory are removed from Cloud Files.

In every attempt I've come across, case 1 happens. In most attempts, Case 2 happens as well.

I intend to provide exact Cloud Files api logs to help track down the issue once they're available. (API logs and CDN logs are generally produced with a few hours' delay due to sheer volume). I'm also looking to get version information for users experiencing this issue.

So far, I can state that this has occurred on 4.3.1 for Windows (Server 2008)

Change History (3)

comment:1 Changed on Jun 16, 2013 at 6:51:54 PM by dkocher

  • Component changed from core to cloudfiles
  • Milestone set to 4.3.2
  • Owner set to dkocher
  • Priority changed from normal to high
  • Status changed from new to assigned

comment:2 Changed on Jun 29, 2013 at 2:02:38 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Jun 29, 2013 at 2:06:25 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

You can provide the transcript from the log drawer View → Toggle Log Drawer. It is expected that when you rename a placeholder object, all subobjects are renamed to the new key name format as well. This is implemented by copying over the object and then deleting the object.

Note: See TracTickets for help on using tickets.
swiss made software