Cyberduck Mountain Duck CLI

#7310 reopened defect

Edited file not uploaded after save

Reported by: timsk Owned by: dkocher
Priority: normal Milestone: 8.0
Component: core Version: 7.4.0
Severity: normal Keywords: editor upload
Cc: bob@… Architecture: Intel
Platform: macOS 10.15

Description

I'm having exactly the same problem as described in issue #5376, but that was apparently resolved 3 years ago.

I connect to an FTP server; I hit cmd-K to edit a file; the file opens up in my text editor; I edit the file and save it; and *sometimes* it's uploaded back up to the server immediately after saving. Sometimes it doesn't. Today, I've just attempted the same edit four times in a row, and it won't upload.

It's not difficult to work around the problem — drag the file from Cyberduck to Finder, open/edit/save the file, then drag it back again — but it's more hassle than it should be.

I was using 4.2.1, and have just updated it to 4.3.1, but the issue is still present. I'm on Mac OS X 10.7.5 and my editor is Emacs 24.1.

Change History (8)

comment:1 Changed on Jun 24, 2013 at 11:23:15 PM by dkocher

  • Milestone set to 4.3.2
  • Owner set to dkocher
  • Status changed from new to assigned

Possible duplicate for #7248.

comment:2 Changed on Jun 29, 2013 at 12:53:56 PM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

comment:4 Changed on Jul 11, 2013 at 9:45:19 PM by dkocher

As a workaround, refresh the directory listing (⌘-R) before attempting to edit the file again or update to the latest snapshot build available.

comment:5 in reply to: ↑ description Changed on Jun 14, 2020 at 7:57:59 PM by DrAltoids

  • Architecture set to Intel
  • Cc bob@… added
  • Keywords editor upload added
  • Milestone changed from 4.4 to 8.0
  • Platform set to macOS 10.15
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version changed from 4.3.1 to 7.4.0

Replying to timsk:

I'm having exactly the same problem as described in issue #5376, but that was apparently resolved 3 years ago.

I connect to an FTP server; I hit cmd-K to edit a file; the file opens up in my text editor; I edit the file and save it; and *sometimes* it's uploaded back up to the server immediately after saving. Sometimes it doesn't. Today, I've just attempted the same edit four times in a row, and it won't upload.

Summary

I have been a licensed user of Cyberduck for years and have experienced this issue for years. I am experiencing it again. Please don't dismiss this issue. It is unresolved. It needs to be fully resolved.

  • Cyberduck version: 7.4.0 (32960)
  • Mac OS: 10.15.4 (19E287)
  • Protocol: SFTP
  • Authentication: SSH key
  • Editors tried: Atom 1.48.0 and SubEthaEdit 5.1.3 (9672) -- both exhibit the symptoms described below
  • Remote server:
    • Virtualization: kvm
    • Operating System: CentOS Linux 7 (Core)
    • Kernel: Linux 3.10.0-1062.12.1.el7.x86_64
    • Architecture: x86-64

Symptoms

Open connection to the remote server. From the file browser, double-click on a file to edit it. It opens as expected in the default browser. Make a change and save... if this is done within a minute or two, the file saves locally and uploads as expected. But if more than a few minutes elapse from the time of download, the save will happen locally and the upload WILL NOT TAKE PLACE. If I do not pay careful attention to the notification pop-up associated with the upload, or more specifically the LACK of pop-up due to the non-uploading of my file, I will lose track of changes not actually made to the file on the remote server. This leads to all sorts of issues, not just inconvenience.

Workaround

IF I catch the fact that the upload did not happen, I select-all in the editor window and close the editor's buffer, double-click again on the file in Cyberduck to re-open the editor window, select-all, delete, paste, save, and watch for the upload confirmation.

Last edited on Jun 14, 2020 at 7:59:24 PM by DrAltoids (previous) (diff)

comment:6 Changed on Jun 19, 2020 at 1:22:17 PM by TimAnthonyAlexander

  • Resolution set to fixed
  • Status changed from reopened to closed

I had this exact problem and fixed it:

I use vim (Mac OS X 10.15) and with vim it would only upload the first time. I noticed that with other editors it worked fine. So I had to find the difference between these two editors. The main difference in saving files was that vim created a temporary file before saving (~filename.filetype). I disabled this (in vim with "set noswapfile", "set nobackup", "set nowritebackup"). After that, it worked perfectly fine! Hope this helps!

Just try to find a way to disable these temporary files.

comment:7 Changed on Aug 7, 2020 at 8:30:03 AM by AdditionalPylons

I have the exact same problem. I am using OS X Catalina 10.15.5, latest Cyberduck 7.4.1 (33065) and BBEdit 13.1.3 (414064, 64-bit, sandboxed). The only possible reason I can think of that caused it for me is that I had Cyberduck and BBEdit running, and then BBEdit checked for updates and asked to install the latest version. This moved my BBEdit application to the Trash, creating the new one in the proper Applications directory. Cyberduck however from then downloads the temporary file to the Trash folder. Perhaps this causes a problem?

To illustrate with an example: If my server (I connect over SFTP/SSH if that matters) contains a file index.php which I am trying to edit using by pressing cmd-K, then a temporary file index.php 10-08-46-833.php is created in the Trash folder. Perhaps Cyberduck uses the location of the BBEdit app, and maybe there are some permission issues when the temporary file is created in the ~/Trash folder? Or perhaps there is a system feature that is there to make sure that files with identical names are not overwritten when moved to the Trash folder, and that the reason why it is renamed that there is already a file index.php in the Trash from previous edits?

Now after closing both Cyberduck and BBEdit and opening again, it seems when I press cmd-K to edit with BBEdit, the file is instead downloaded to /private/var/folder/05/zmdr_...../T/0d02fd....../ followed by the path on the server. (The dots here represent alphanumerical strings with some dashes in between, I guess produced by some checksum calculation or generated randomly.) Saving changes then correctly uploads to the server.

There is also never a problem if I choose to open with TextEdit instead. Then, correctly, the name of the file that TextEdit opens is index.php (downloaded to the same /private/var/folder/05/..... path as above), and the file is correctly uploaded after I save the edits.

TL;DR: Try quitting both BBEdit and Cyberduck and open them again.

Hope this helps!

comment:8 Changed on Aug 7, 2020 at 11:20:49 AM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened
Note: See TracTickets for help on using tickets.
swiss made software