Cyberduck Mountain Duck CLI

#7374 closed defect (worksforme)

Connection closed without indication error opening directory

Reported by: fontmenu Owned by: dkocher
Priority: normal Milestone: 4.4
Component: ftp Version: 4.3.1
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description (last modified by dkocher)

I have a directory on my web site which contains files for download ranging in size from 50,000 K to 4 MB and I access it by ftp. I have been adding files and symbolic links pointing within that directory. For instance W-TEXT.zip would point to TEXT.zip.

All was OK until recently, when all the sudden CyberDuck was not able to open 'delivery'. When I double click on it, it says :

Listing directory delivery

And the rotating symbol of activity shows it is working. After a couple minutes, an error message appears saying :

I/O Error: Connection closed without indication.

This happens in Mac OS 4.2.1 and 4.3.1.The directory contains 31 files, and 59 symbolic links.

At first I thought it was a server error, but I verified with Filezilla, and it opens reliably instantaneously. I actually had to switch to Filezilla because CyberDuck was not able to access my data.

All seems related to the way CyberDuck gets the directory listing. Hope you will be able to spot the problem and fix it.

Mitch

Change History (7)

comment:1 Changed on Jul 31, 2013 at 1:14:34 PM by fontmenu

  • Description modified (diff)

comment:2 Changed on Jul 31, 2013 at 1:29:18 PM by fontmenu

  • Description modified (diff)

comment:3 Changed on Aug 18, 2013 at 12:10:31 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Aug 18, 2013 at 12:11:33 PM by dkocher

  • Component changed from core to ftp
  • Milestone set to 4.4
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Time out opening folder to Connection closed without indication error opening directory

comment:5 follow-up: Changed on Aug 18, 2013 at 12:12:30 PM by dkocher

Can you reproduce this issue with the latest snapshot build available? Please post the transcript from the log drawer (⌘-L).

comment:6 Changed on Aug 18, 2013 at 4:01:20 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:7 in reply to: ↑ 5 Changed on Aug 18, 2013 at 6:27:40 PM by fontmenu

Replying to dkocher:

Can you reproduce this issue with the latest snapshot build available? Please post the transcript from the log drawer (⌘-L).

Sorry, Log drawer is empty... It may have been reporting something when I posted a while ago, though :(

Note: See TracTickets for help on using tickets.