Cyberduck Mountain Duck CLI

#7398 closed defect (fixed)

Crash trying to Quick Look an HTML file

Reported by: jim white Owned by:
Priority: normal Milestone: 4.4
Component: core Version: 4.3.1
Severity: major Keywords:
Cc: Architecture:
Platform:

Description

Like the title says. Been using Cyberduck just fine since last year. Just within the last day or so trying to Quick Look crashes when I try to view an HTML file. My system (MacBook Air, Mac OS X 10.8.4) hasn't had any updates recently.

Attachments (4)

cyberduck-log.txt (8.1 KB) - added by jim white on Aug 13, 2013 at 4:37:16 AM.
copy&paste of system.log with "ch.sudo.cyberduck logging debug".
Cyberduck_2013-08-12-212623_Fawkes.crash (90.3 KB) - added by jim white on Aug 13, 2013 at 4:39:04 AM.
/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-12-212623_Fawkes.crash
Cyberduck_2013-08-12-232629_Fawkes.crash (94.4 KB) - added by jim white on Aug 13, 2013 at 6:29:59 AM.
/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-12-232629_Fawkes.crash
Cyberduck_2013-08-13-001559_Fawkes.crash (94.0 KB) - added by jim white on Aug 13, 2013 at 7:18:58 AM.
/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-13-001559_Fawkes.crash

Download all attachments as: .zip

Change History (11)

Changed on Aug 13, 2013 at 4:37:16 AM by jim white

copy&paste of system.log with "ch.sudo.cyberduck logging debug".

Changed on Aug 13, 2013 at 4:39:04 AM by jim white

/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-12-212623_Fawkes.crash

comment:1 Changed on Aug 13, 2013 at 6:09:17 AM by dkocher

Thanks for your bug report including system log and crash report. Can you reproduce this issue with the latest snapshot build available?

comment:2 Changed on Aug 13, 2013 at 6:29:23 AM by jim white

With the Beta:

Aug 12 23:26:07 Fawkes.local WindowServer[98]: CGXSetWindowBackgroundBlurRadius: Invalid window 0xffffffff
Aug 12 23:26:27 Fawkes.local WindowServer[98]: CGXSetWindowBackgroundBlurRadius: Invalid window 0xffffffff
Aug 12 23:26:27 Fawkes.local Cyberduck[1626]: -[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x100171240
Aug 12 23:26:27 Fawkes.local Cyberduck[1626]: An uncaught exception was raised
Aug 12 23:26:27 Fawkes.local Cyberduck[1626]: -[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x100171240
Aug 12 23:26:27 Fawkes.local Cyberduck[1626]: (
		0   CoreFoundation                      0x00007fff98fdfb06 __exceptionPreprocess + 198
		1   libobjc.A.dylib                     0x00007fff8e38f3f0 objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff9907640a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
		3   CoreFoundation                      0x00007fff98fce02e ___forwarding___ + 414
		4   CoreFoundation                      0x00007fff98fcde18 _CF_forwarding_prep_0 + 232
		5   librococoa.dylib                    0x000000010b6446b9 -[CDListView previewPanel:frameForURL:] + 209
		6   librococoa.dylib                    0x000000010b644854 -[CDListView previewPanel:sourceFrameOnScreenForPreviewItem:] + 102
		7   QuickLookUI                         0x00007fff91a5e2df -[QLPreviewPanel _currentItemFrame] + 230
		8   QuickLookUI                         0x00007fff91a5f131 -[QLPreviewPanel _openWithEffect:willOpen:toFullscreen:] + 1196
		9   libjnidispatch.dylib                0x000000010b5c9bbc ffi_call_unix64 + 76
		10  ???                                 0x00007fff5fbf9d00 0x0 + 140734799781120
	)
Aug 12 23:26:27 Fawkes.local Cyberduck[1626]: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x100171240'
	*** First throw call stack:
	(
		0   CoreFoundation                      0x00007fff98fdfb06 __exceptionPreprocess + 198
		1   libobjc.A.dylib                     0x00007fff8e38f3f0 objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff9907640a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
		3   CoreFoundation                      0x00007fff98fce02e ___forwarding___ + 414
		4   CoreFoundation                      0x00007fff98fcde18 _CF_forwarding_prep_0 + 232
		5   librococoa.dylib                    0x000000010b6446b9 -[CDListView previewPanel:frameForURL:] + 209
		6   librococoa.dylib                    0x000000010b644854 -[CDListView previewPanel:sourceFrameOnScreenForPreviewItem:] + 102
		7   QuickLookUI                         0x00007fff91a5e2df -[QLPreviewPanel _currentItemFrame] + 230
		8   QuickLookUI                         0x00007fff91a5f131 -[QLPreviewPanel _openWithEffect:willOpen:toFullscreen:] + 1196
		9   libjnidispatch.dylib                0x000000010b5c9bbc ffi_call_unix64 + 76
		10  ???                                 0x00007fff5fbf9d00 0x0 + 140734799781120
	)
Aug 12 23:26:28 Fawkes.local WindowServer[98]: CGXDisableUpdate: UI updates were forcibly disabled by application "Cyberduck" for over 1.00 seconds. Server has re-enabled them.
Aug 12 23:26:28 Fawkes.local WindowServer[98]: CGXDeferSurfaces : Invalid source window 1003
Aug 12 23:26:28 Fawkes.local WindowServer[98]: CGXDeferSurfaces : Invalid source window 1007
Aug 12 23:26:29 Fawkes com.apple.launchd.peruser.501[180] ([0x0-0x9b09b].ch.sudo.cyberduck[1626]): Job appears to have crashed: Abort trap: 6
Aug 12 23:26:29 Fawkes.local ReportCrash[1633]: Saved crash report for Cyberduck[1626] version 4.4 (12492) to /Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-12-232629_Fawkes.crash
 

Changed on Aug 13, 2013 at 6:29:59 AM by jim white

/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-12-232629_Fawkes.crash

comment:3 Changed on Aug 13, 2013 at 7:17:48 AM by jim white

Snapshot:

Aug 13 00:15:36 Fawkes.local WindowServer[98]: CGXSetWindowBackgroundBlurRadius: Invalid window 0xffffffff
Aug 13 00:15:58 --- last message repeated 1 time ---
Aug 13 00:15:58 Fawkes.local Cyberduck[2136]: -[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x110112650
Aug 13 00:15:58 Fawkes.local Cyberduck[2136]: An uncaught exception was raised
Aug 13 00:15:58 Fawkes.local Cyberduck[2136]: -[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x110112650
Aug 13 00:15:58 Fawkes.local Cyberduck[2136]: (
		0   CoreFoundation                      0x00007fff98fdfb06 __exceptionPreprocess + 198
		1   libobjc.A.dylib                     0x00007fff8e38f3f0 objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff9907640a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
		3   CoreFoundation                      0x00007fff98fce02e ___forwarding___ + 414
		4   CoreFoundation                      0x00007fff98fcde18 _CF_forwarding_prep_0 + 232
		5   librococoa.dylib                    0x000000010b6446b9 -[CDListView previewPanel:frameForURL:] + 209
		6   librococoa.dylib                    0x000000010b644854 -[CDListView previewPanel:sourceFrameOnScreenForPreviewItem:] + 102
		7   QuickLookUI                         0x00007fff91a5e2df -[QLPreviewPanel _currentItemFrame] + 230
		8   QuickLookUI                         0x00007fff91a5f131 -[QLPreviewPanel _openWithEffect:willOpen:toFullscreen:] + 1196
		9   libjnidispatch.dylib                0x000000010b5c9bbc ffi_call_unix64 + 76
		10  ???                                 0x00007fff5fbf9da0 0x0 + 140734799781280
	)
Aug 13 00:15:58 Fawkes.local Cyberduck[2136]: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[ProxyForJava outlineView:objectValueForTableColumn:row:]: unrecognized selector sent to instance 0x110112650'
	*** First throw call stack:
	(
		0   CoreFoundation                      0x00007fff98fdfb06 __exceptionPreprocess + 198
		1   libobjc.A.dylib                     0x00007fff8e38f3f0 objc_exception_throw + 43
		2   CoreFoundation                      0x00007fff9907640a -[NSObject(NSObject) doesNotRecognizeSelector:] + 186
		3   CoreFoundation                      0x00007fff98fce02e ___forwarding___ + 414
		4   CoreFoundation                      0x00007fff98fcde18 _CF_forwarding_prep_0 + 232
		5   librococoa.dylib                    0x000000010b6446b9 -[CDListView previewPanel:frameForURL:] + 209
		6   librococoa.dylib                    0x000000010b644854 -[CDListView previewPanel:sourceFrameOnScreenForPreviewItem:] + 102
		7   QuickLookUI                         0x00007fff91a5e2df -[QLPreviewPanel _currentItemFrame] + 230
		8   QuickLookUI                         0x00007fff91a5f131 -[QLPreviewPanel _openWithEffect:willOpen:toFullscreen:] + 1196
		9   libjnidispatch.dylib                0x000000010b5c9bbc ffi_call_unix64 + 76
		10  ???                                 0x00007fff5fbf9da0 0x0 + 140734799781280
	)
Aug 13 00:15:59 Fawkes.local WindowServer[98]: CGXDeferSurfaces : Invalid source window 3671
Aug 13 00:15:59 Fawkes com.apple.launchd.peruser.501[180] ([0x0-0x10c10c].ch.sudo.cyberduck[2136]): Job appears to have crashed: Abort trap: 6
Aug 13 00:15:59 Fawkes.local ReportCrash[2146]: Saved crash report for Cyberduck[2136] version 4.4 (12495) to /Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-13-001559_Fawkes.crash

Changed on Aug 13, 2013 at 7:18:58 AM by jim white

/Users/jim/Library/Logs/DiagnosticReports/Cyberduck_2013-08-13-001559_Fawkes.crash

comment:4 Changed on Aug 13, 2013 at 7:21:07 AM by jim white

Actually I did do something to my system within the last couple days: update macports with "sudo port selfupdate ; sudo port upgrade outdated".

Is there some way for MacPorts to interfere with Cyberduck?

comment:5 Changed on Aug 13, 2013 at 9:16:12 AM by dkocher

As a workaround, change the browser to Outline View (⌘-2)

comment:6 Changed on Aug 13, 2013 at 9:19:15 AM by jim white

That does the trick! Thanks!

comment:7 Changed on Aug 13, 2013 at 9:27:35 AM by dkocher

  • Milestone set to 4.4
  • Resolution set to fixed
  • Status changed from new to closed

In r12507.

Note: See TracTickets for help on using tickets.
swiss made software