Cyberduck Mountain Duck CLI

Opened 5 years ago

Closed 5 years ago

#7427 closed defect (fixed)

PRET support for downloads not working anymore.

Reported by: flo___ Owned by: dkocher
Priority: normal Milestone: 4.4
Component: ftp Version: 4.3.1
Severity: normal Keywords:
Cc: 5772 Architecture:
Platform:

Description (last modified by dkocher)

PRET support for downloads not working anymore.

It seems to be the same defect as the #5772.

Login is working but download is not. Error is :

 "500 You need to use a client supporting PRET (PRE Transfer) to use PASV." 

Tested and reproduced on Windows and OSX.

Change History (12)

comment:1 Changed 5 years ago by dkocher

  • Description modified (diff)
  • Milestone set to 4.4

comment:2 Changed 5 years ago by dkocher

Can you please post the transcript from the log drawer (⌘-L) of the Transfers window.

comment:3 Changed 5 years ago by dkocher

Can you reproduce this issue with the latest snapshot build available.

comment:4 Changed 5 years ago by flo___

I've tested with the build 12675, same issue :

220 DRFTPD
AUTH TLS
234 AUTH TLS successful
SYST
530 Not logged in.
FEAT
530 Not logged in.
USER ****
331 Password required for ****.
PASS ********
230- 
230-         Welcome to the future of FXP:ing
230-      ___      _____________  ___
230-     / _ \____/ __/_  __/ _ \/ _ \
230-    / // / __/ _/  / / / ___/ // /
230-   /____/_/ /_/   /_/ /_/  /____/
230-                   DistRibuted FTP Daemon
230-                        http://drftpd.org
230 **** logged in successfully.
PBSZ 0
200 Command okay
PROT P
200 Command okay
TYPE I
200 Command okay
PASV
500 You need to use a client supporting PRET (PRE Transfer) to use PASV
PORT 192,168,1,22,213,66
501- ==YOU'RE BEHIND A NAT ROUTER==
501- Configure the firewall settings of your FTP client
501-   to use your real IP: **.**.**.**
501- And set up port forwarding in your router.
501- Or you can just use a PRET capable client, see
501    http://drftpd.org/ for PRET capable clients

comment:5 Changed 5 years ago by dkocher

  • Status changed from new to assigned

We fail to detect PRET support by the server because we receive a 530 reply when requesting features with FEAT before we are authenticated. We should retry the FEAT request after logging in.

comment:6 Changed 5 years ago by dkocher

In r12690.

comment:7 Changed 5 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:8 Changed 5 years ago by marco areosa

Lastest snashtop build

220 DRFTPD +
FEAT
530 Not logged in.
USER Admin
331 Password required for Admin.
PASS ********
230 Admin logged in successfully.
SYST
215 UNIX system type.
TYPE I
200 Command okay
PASV
500 You need to use a client supporting PRET (PRE Transfer) to use PASV
PORT 192,168,2,5,192,137
501- ==YOU'RE BEHIND A NAT ROUTER==
501- Configure the firewall settings of your FTP client
501-   to use your real IP: xxx.xxx.xxx.xxx
501- And set up port forwarding in your router.
501- Or you can just use a PRET capable client, see
501    http://drftpd.org/ for PRET capable clients

comment:9 Changed 5 years ago by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:10 Changed 5 years ago by dkocher

The issue is that we cache the response to FEAT but DRFTPD returns a 530 error when requesting features before logged in.

comment:11 Changed 5 years ago by dkocher

You can workaround this by connecting using a FTP-TLS connection as then we request server features only after successful login.

comment:12 Changed 5 years ago by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r13280.

Note: See TracTickets for help on using tickets.
swiss made software