Cyberduck Mountain Duck CLI

#7445 closed defect (fixed)

Could not parse response code

Reported by: sheldon kennedy Owned by: dkocher
Priority: high Milestone: 4.4
Component: ftp Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.8

Description (last modified by dkocher)

Note that I am using: Version 4.4 (12675)

Woke up this morning after upgrading, never had this problem before. Started connecting to a client's server and then got this:

Listing directory failed

Could not parse response code.
Server Reply: 02-13-13  11:38AM       <DIR>          aspnet_client.
220 Microsoft FTP Service
SYST
530 Please login with USER and PASS.
FEAT
530 Please login with USER and PASS.
USER sr1776
331 Password required for sr1776.
PASS ********
230 User sr1776 logged in.
PWD
257 "/sr1776" is current directory.
STAT /sr1776
213-status of /sr1776:
05-10-13  11:45AM                 3703 activity.php
CWD /sr1776

Log view is below

220 Microsoft FTP Service
SYST
530 Please login with USER and PASS.
FEAT
530 Please login with USER and PASS.
USER sr1776
331 Password required for sr1776.
PASS ********
230 User sr1776 logged in.
PWD
257 "/sr1776" is current directory.
STAT /sr1776
213-status of /sr1776:
05-10-13  11:45AM                 3703 activity.php
CWD /sr1776
NOOP
220 Microsoft FTP Service
SYST
530 Please login with USER and PASS.
FEAT
530 Please login with USER and PASS.
USER sr1776
331 Password required for sr1776.
PASS ********
230 User sr1776 logged in.
QUIT
221

Change History (9)

comment:1 Changed on Sep 12, 2013 at 1:46:46 PM by sheldon kennedy

  • Description modified (diff)
  • Version changed from 4.3.1 to Nightly Build

comment:2 Changed on Sep 12, 2013 at 1:54:56 PM by dkocher

  • Component changed from core to ftp
  • Description modified (diff)
  • Milestone set to 4.4
  • Owner set to dkocher

comment:3 Changed on Sep 12, 2013 at 2:27:55 PM by dkocher

  • Summary changed from Won't list Directory to Could not parse response code

comment:4 in reply to: ↑ description Changed on Sep 13, 2013 at 1:33:01 PM by dkocher

Replying to sheldon kennedy:

The interoperability failure is caused by the malformed response

213-status of /sr1776:

comment:5 Changed on Sep 15, 2013 at 8:34:20 AM by dkocher

Drop use of STAT in r12885 on failure reading reply code.

comment:6 Changed on Sep 15, 2013 at 8:43:57 AM by dkocher

Added tests in r12894.

Last edited on Sep 15, 2013 at 8:48:29 AM by dkocher (previous) (diff)

comment:7 Changed on Sep 15, 2013 at 8:48:44 AM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Please update to the latest snapshot build available.

comment:8 follow-up: Changed on Sep 15, 2013 at 12:51:24 PM by sheldon kennedy

Wow you are fast. Snapshot 12881 is the latest I see, so I'll wait a bit, perhaps it's still building on your end.

Donation coming your way.

comment:9 in reply to: ↑ 8 Changed on Sep 15, 2013 at 6:18:39 PM by dkocher

Replying to sheldon kennedy:

Wow you are fast. Snapshot 12881 is the latest I see, so I'll wait a bit, perhaps it's still building on your end.

Donation coming your way.

Available in a few minutes. Please reopen this ticket if the issue persists with the latest build as I could not replicate the issue 1:1 against a live system. Would it be possible to get a test account on the server?

Note: See TracTickets for help on using tickets.
swiss made software