Cyberduck Mountain Duck CLI

#7459 closed defect (fixed)

File rename temporality breaks webdav download

Reported by: aaron@… Owned by: dkocher
Priority: normal Milestone: 4.4
Component: webdav Version: 4.3.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.8

Description (last modified by dkocher)

File rename via webdav goes through successfully. Trying to then download the renamed file via webdav fails part way through the download. File can be downloaded via other clients fine. If you try to download a different file via CyberDuck (successfully), and then reattempt to download the re-named file, the download works successfully.

Steps to reproduce:

  • (1) Rename file via CyberDuck (webdav https).
  • (2) Try to download that file via webdav. [will fail partway through download, download via web portal works]

NOTE: the file downloads 100% but CyberDuck reports an error because it reports the whole file size is twice the size for some reason. Appears to be a client caching bug because the logs (see comment below) show that the file attempts to download at the old name first, then retries at the new name.

Optional: (3) download a different file via webdav. then try to download the re-named file again. File will download successfully.

-------------------------------
SERVER LOG:
-------------------------------
64.245.0.218 -  -  [25/Sep/2013:21:57:02 +0000] "GET /dav/Demo%20Upload/012_Sample%20PDF.pdf HTTP/1.1" 404 - "-" "Cyberduck/4.3.1 (Mac OS X/10.8.5) (i386)" 58 58
64.245.0.218 -  -  [25/Sep/2013:21:57:02 +0000] "GET /dav/Demo%20Upload/012_Sample%20PDF%20%28rename%20on%20cyber%29.pdf HTTP/1.1" 200 72309 "-" "Cyberduck/4.3.1 (Mac OS X/10.8.5) (i386)" 139 139

Change History (3)

comment:1 Changed on Sep 26, 2013 at 8:34:03 PM by dkocher

  • Component changed from core to webdav
  • Description modified (diff)
  • Milestone set to 4.4
  • Owner set to dkocher

comment:2 Changed on Sep 26, 2013 at 8:34:21 PM by dkocher

  • Description modified (diff)

comment:3 Changed on Sep 26, 2013 at 8:37:03 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

I cannot reproduce this issue with the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software