Cyberduck Mountain Duck CLI

#7483 closed defect (fixed)

Connect to webdav server with invalid certificate

Reported by: hmchan Owned by: yla
Priority: normal Milestone: 4.4.1
Component: webdav Version: 4.3.1
Severity: normal Keywords:
Cc: Architecture:
Platform: Windows 7

Description

When connect to webdav server with invalid certificate, there is a prompt to let you choose "Continue", "Disconnect", "Show Certificate" and a checkbox "Always Trust".

If click "Continue", the webdav server can be connected successfully.

However, if tick the checkbox "Always Trust" and then click "Continue", the webdav server cannot be connected and the status bar will show "Disconnected".

Please help to check and fix it. Thanks.

Change History (10)

comment:1 Changed on Oct 9, 2013 at 10:45:49 AM by dkocher

  • Component changed from core to webdav
  • Milestone set to 4.4
  • Owner set to yla

comment:2 follow-up: Changed on Oct 15, 2013 at 9:58:50 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with the latest snapshot build available.

comment:3 in reply to: ↑ 2 Changed on Oct 16, 2013 at 2:01:30 AM by hmchan

Replying to dkocher:

I cannot reproduce this issue with the latest snapshot build available.

I tried snapshot build version 4.4 (13235) but the problem still exists.

comment:4 Changed on Oct 16, 2013 at 2:03:16 AM by hmchan

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:5 Changed on Oct 16, 2013 at 7:03:35 AM by dkocher

Is this server reachable from the Internet?

comment:6 Changed on Oct 18, 2013 at 7:51:05 AM by yla

  • Resolution set to fixed
  • Status changed from reopened to closed

Tried to replicate the issue with a local WebDAV server and a self-signed certificate. The connection could be establish in both cases (Always Trust off/on).

I'm happy to test against your server if it's reachable from the Internet.

comment:7 follow-up: Changed on Nov 4, 2013 at 2:51:03 AM by hmchan

I tried with IIS WebDav server. The problem appears.

But tried with Apache WebDav server. The problem does not appear.

comment:8 in reply to: ↑ 7 Changed on Nov 4, 2013 at 10:41:08 AM by dkocher

Replying to hmchan:

I tried with IIS WebDav server. The problem appears.

But tried with Apache WebDav server. The problem does not appear.

What is the address of the IIS server? Is it reachable over the Internet?

comment:9 Changed on Nov 4, 2013 at 10:57:39 AM by dkocher

  • Milestone changed from 4.4 to 4.4.1

comment:10 Changed on Nov 8, 2013 at 1:05:55 AM by hmchan

Sorry. My IIS WebDav Server is not reachable over Internet.

Note: See TracTickets for help on using tickets.
swiss made software