Cyberduck Mountain Duck CLI

#7516 closed defect (fixed)

Can't drag files from Cyberduck-window to the machine

Reported by: jarno Owned by: dkocher
Priority: normal Milestone: 4.4.1
Component: core Version: 4.4
Severity: major Keywords: Drag
Cc: Architecture:
Platform: Mac OS X 10.9

Description

When trying to drag files or folders from SFTP-window to my machine, Cyberduck 4.4 just keeps "selecting" files within SFTP-window, and does not drag them to Finder. (Mavericks, MBP-Retina, mid 2012). Dragging from Finder -> Cyberduck works fine.

Lots of errors to the system log when trying to drag:

Cyberduck[1373]: [main] ERROR org.rococoa.callback - Exception calling method for selector tableView:writeRowsWithIndexes:toPasteboard:

java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170) at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52) at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82) at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) at java.lang.reflect.Method.invoke(Method.java:606) at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:449) at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:479) at com.sun.jna.Native.invokeVoid(Native Method) at com.sun.jna.Function.invoke(Function.java:334) at com.sun.jna.Function.invoke(Function.java:278) at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111) at com.sun.jna.Library$Handler.invoke(Library.java:232) at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source) at org.rococoa.Foundation.send(Foundation.java:208) at org.rococoa.Foundation.send(Foundation.java:194) at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269) at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232) at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191) at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>) at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:156)

Caused by: java.lang.NullPointerException

at ch.cyberduck.ui.cocoa.BrowserTableDataSource.writeItemsToPasteBoard(BrowserTableDataSource.java:435) at ch.cyberduck.ui.cocoa.BrowserListViewModel.tableView_writeRowsWithIndexes_toPasteboard(BrowserListViewModel.java:140) ... 25 more

If "as Outline" selected from view-menu, dragging works as it suppose, without any errors in the system log. So, if i get this right, problems occurs only in "as List" -view.

Change History (3)

comment:1 Changed on Oct 28, 2013 at 1:07:13 PM by dkocher

  • Milestone set to 4.4.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Oct 28, 2013 at 1:58:06 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r13615.

comment:3 Changed on Nov 13, 2013 at 3:40:25 PM by dkocher

#7596 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software