Cyberduck Mountain Duck CLI

#7533 closed defect (fixed)

Refresh listing window after webdav upload

Reported by: gdhnz Owned by: dkocher
Priority: normal Milestone: 4.4.1
Component: webdav Version: 4.4
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

When I upload a file via webdav, I have to manually refresh the listing window before the uploaded file(s) will show up. If I create a folder, the listing window updates and I can see the new folder.

Deleting a file and the listing window updates appropriately and the file disappears.

Change History (8)

comment:1 Changed on Oct 31, 2013 at 6:20:56 AM by dkocher

  • Milestone set to 4.4.1
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot replicate the issue here. Refreshing the directory listing will not work if you subsequently upload a file already in the transfer window but only the first time.

comment:2 follow-up: Changed on Oct 31, 2013 at 6:26:51 AM by gdhnz

I'm not talking about refreshing the listing while still uploading a file. The listing window doesn't automatically update after a file has finished uploading and is no longer in the transfer window.

v4.2.1 didn't have this issue. After the file finished uploading, the listing window refreshed and the file showed up.

comment:3 in reply to: ↑ 2 Changed on Oct 31, 2013 at 2:45:28 PM by dkocher

Replying to gdhnz:

I'm not talking about refreshing the listing while still uploading a file. The listing window doesn't automatically update after a file has finished uploading and is no longer in the transfer window.

v4.2.1 didn't have this issue. After the file finished uploading, the listing window refreshed and the file showed up.

Yes, I understand what you mean but cannot reproduce the issue.

comment:4 follow-up: Changed on Oct 31, 2013 at 7:44:56 PM by gdhnz

Thanks. I'm guessing it's got something to do with the Oracle Content Server we're using as a webdav server and Cyberduck refreshes the listing before the server has finished processing the file after uploading.

We'll keep using v4.2.1 in the meantime.

comment:5 in reply to: ↑ 4 Changed on Oct 31, 2013 at 8:10:01 PM by dkocher

Replying to gdhnz:

Thanks. I'm guessing it's got something to do with the Oracle Content Server we're using as a webdav server and Cyberduck refreshes the listing before the server has finished processing the file after uploading.

We'll keep using v4.2.1 in the meantime.

Please try the latest 4.4.1 snapshot build available which might fix this with a change in r13590.

comment:6 follow-up: Changed on Oct 31, 2013 at 10:02:26 PM by gdhnz

The 4.4.1 snapshot works correctly. The listing window refreshes and shows the file after upload is completed.

Thanks.

comment:7 in reply to: ↑ 6 Changed on Oct 31, 2013 at 10:07:31 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to gdhnz:

The 4.4.1 snapshot works correctly. The listing window refreshes and shows the file after upload is completed.

Thanks.

Thanks for testing and feedback.

comment:8 Changed on Oct 31, 2013 at 10:07:59 PM by dkocher

  • Component changed from interface to webdav
  • Resolution set to fixed
  • Status changed from reopened to closed

Fix in r13590.

Note: See TracTickets for help on using tickets.
swiss made software