Cyberduck Mountain Duck CLI

#7542 closed defect (fixed)

Copy URL doesn't work for files with spaces.

Reported by: xbuzz Owned by:
Priority: normal Milestone: 4.4.1
Component: openstack Version: 4.4
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.9

Description (last modified by dkocher)

Spaces in the file or directory name now throw an error in the system console. This was introduced with OS X Mavericks...

Below is an example of the error message seen. When the space was replaced with an underscore it worked fine.


11/3/13 3:25:43.739 PM Cyberduck[8181]: [main] ERROR org.rococoa.callback - Exception calling method for selector numberOfItemsInMenu:

java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:449)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:479)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:334)
	at com.sun.jna.Function.invoke(Function.java:278)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:232)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:156)
Caused by: java.lang.IllegalArgumentException: Illegal character in path at index 115: https://storage101.dfw1.clouddrive.com/v1/MossoCloudFS_3ac5aba5-b4ae-45fc-9f1f-82a9c6aeee72/celebrityawesome/Amanda Bynes and Mom.jpg?temp_url_sig=eztOfTrZxycwlg4Yqpq/PBgtr8A=&temp_url_expires=1383513943
	at java.net.URI.create(URI.java:859)
	at ch.cyberduck.core.openstack.SwiftUrlProvider.createTempUrl(SwiftUrlProvider.java:154)
	at ch.cyberduck.core.openstack.SwiftUrlProvider.toUrl(SwiftUrlProvider.java:93)
	at ch.cyberduck.ui.cocoa.delegate.CopyURLMenuDelegate.getURLs(CopyURLMenuDelegate.java:56)
	at ch.cyberduck.ui.cocoa.delegate.URLMenuDelegate.numberOfItemsInMenu(URLMenuDelegate.java:76)
	... 25 more
Caused by: java.net.URISyntaxException: Illegal character in path at index 115: https://storage101.dfw1.clouddrive.com/v1/MossoCloudFS_3ac5aba5-b4ae-45fc-9f1f-82a9c6aeee72/celebrityawesome/Amanda Bynes and Mom.jpg?temp_url_sig=eztOfTrZxycwlg4Yqpq/PBgtr8A=&temp_url_expires=1383513943
	at java.net.URI$Parser.fail(URI.java:2829)
	at java.net.URI$Parser.checkChars(URI.java:3002)
	at java.net.URI$Parser.parseHierarchical(URI.java:3086)
	at java.net.URI$Parser.parse(URI.java:3034)
	at java.net.URI.<init>(URI.java:595)
	at java.net.URI.create(URI.java:857)
	... 29 more

Change History (2)

comment:1 Changed on Nov 4, 2013 at 10:36:38 AM by dkocher

  • Component changed from core to openstack
  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from OSX Mavericks - Copy URL doesn't work for files with spaces. to Copy URL doesn't work for files with spaces.

In r13586.

comment:2 Changed on Nov 4, 2013 at 10:36:51 AM by dkocher

Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software