Cyberduck Mountain Duck CLI

#7543 closed defect (fixed)

Upload is not working

Reported by: patrices Owned by: yla
Priority: highest Milestone: 4.4.1
Component: core Version: 4.4
Severity: critical Keywords: upload problem
Cc: Architecture:
Platform: Windows 7

Description

After the last update to CyberDuck I am unable to upload any files to my server by any means, including drop and drag, copy and paste, and using the upload feature in the program. This must be fixed ASAP. In addition, following the latest update I must constantly refresh to find the files again as they don't show up without refreshing. I've made no changes to my settings or my computer - the problem is in your latest update.

Attachments (2)

Debug-cyberduck (2).log (582.4 KB) - added by chris nolan on Nov 8, 2013 at 2:16:07 PM.
Debug-13924-cyberduck.log (260.6 KB) - added by chris nolan on Nov 8, 2013 at 3:05:05 PM.

Download all attachments as: .zip

Change History (20)

comment:1 Changed on Nov 3, 2013 at 10:34:17 PM by patrices

  • Severity changed from normal to critical

comment:2 Changed on Nov 4, 2013 at 2:16:10 PM by dkocher

  • Milestone set to 4.4.1
  • Owner set to yla

Please attach the logging information found in the cyberduck.log file in the AppData directory.

comment:3 Changed on Nov 4, 2013 at 6:44:01 PM by patrices

Here is what i think you are asking for:

2013-10-24 09:31:28,653 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-24 10:44:49,032 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-24 14:00:59,018 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-24 20:09:25,365 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-25 17:56:15,833 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-31 12:26:44,460 [background-3] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
2013-10-31 12:29:16,736 [background-8] ERROR ch.cyberduck.core.ftp.FTPSession - Error closing connection: FTP response 421 received.  Server closed connection.
Last edited on Nov 4, 2013 at 9:20:05 PM by dkocher (previous) (diff)

comment:4 Changed on Nov 5, 2013 at 4:57:35 PM by yla

Is there any error message displayed or does it just fails silently? Can you please test with the latest snapshot build available and report back?

comment:5 Changed on Nov 5, 2013 at 6:18:04 PM by patrices

I updated with the latest snapshot build and the problem is not resolved. I can delete files from the server, but not upload. There is no error message. The upload screen shows the upload is complete, but 0 B of 0 B is shown as being uploaded (meaning nothing got uploaded). This problem started on Nov. 2. I was able to upload successfully on Oct. 19th.

comment:6 Changed on Nov 7, 2013 at 6:08:56 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Upgrade to the latest snapshot build and post the transcript from the log drawer (⌘-L) if still an issue.

comment:7 Changed on Nov 7, 2013 at 6:43:13 PM by patrices

The update did not change anything. It still shows the upload screen and says the upload was successful but 0 of 0 files were transferred. For some reason, it is not logging this latest attempt. Here's the last entry from the log-in file from 11-5: 2013-11-05 10:13:18,120 [Thread-0] ERROR ch.cyberduck.ui.AbstractController - Exception running cleanup task null java.lang.NullPointerException

at cli.Ch.Cyberduck.Core.Utils.ConvertFromJavaMap(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.TransferPromptModel$FilterAction$InnerTransferPromptFilterWorker.cleanup(Unknown Source) at ch.cyberduck.ui.threading.WorkerBackgroundAction.cleanup(WorkerBackgroundAction.java:51) at ch.cyberduck.ui.AbstractController$BackgroundCallable$1.run(AbstractController.java:181) at cli.System.Delegate.DynamicInvokeImpl(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackDo(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Unknown Source) at cli.System.Threading.ExecutionContext.runTryCode(Unknown Source) at cli.System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(Unknown Source) at cli.System.Threading.ExecutionContext.RunInternal(Unknown Source) at cli.System.Threading.ExecutionContext.Run(Unknown Source) at cli.System.Threading.ExecutionContext.Run(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallback(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbacks(Unknown Source) at cli.System.Windows.Forms.Control.WndProc(Unknown Source) at cli.System.Windows.Forms.ScrollableControl.WndProc(Unknown Source) at cli.System.Windows.Forms.Form.WndProc(Unknown Source) at cli.System.Windows.Forms.Control$ControlNativeWindow.OnMessage(Unknown Source) at cli.System.Windows.Forms.Control$ControlNativeWindow.WndProc(Unknown Source) at cli.System.Windows.Forms.NativeWindow.Callback(Unknown Source) at cli.System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(Unknown Source) at cli.System.Windows.Forms.Application$ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Unknown Source) at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoopInner(Unknown Source) at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoop(Unknown Source) at cli.System.Windows.Forms.Application.RunDialog(Unknown Source) at cli.System.Windows.Forms.Form.ShowDialog(Unknown Source) at cli.Ch.Cyberduck.Ui.Winforms.BaseForm.ShowDialog(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.TransferPromptController.<prompt>b3(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.Threading.SimpleDefaultMainAction.run(Unknown Source) at cli.System.Delegate.DynamicInvokeImpl(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackDo(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Unknown Source) at cli.System.Threading.ExecutionContext.runTryCode(Unknown Source) at cli.System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(Unknown Source) at cli.System.Threading.ExecutionContext.RunInternal(Unknown Source) at cli.System.Threading.ExecutionContext.Run(Unknown Source) at cli.System.Threading.ExecutionContext.Run(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallback(Unknown Source) at cli.System.Windows.Forms.Control.InvokeMarshaledCallbacks(Unknown Source) at cli.System.Windows.Forms.Control.WndProc(Unknown Source) at cli.System.Windows.Forms.ScrollableControl.WndProc(Unknown Source) at cli.System.Windows.Forms.Form.WndProc(Unknown Source) at cli.System.Windows.Forms.Control$ControlNativeWindow.OnMessage(Unknown Source) at cli.System.Windows.Forms.Control$ControlNativeWindow.WndProc(Unknown Source) at cli.System.Windows.Forms.NativeWindow.Callback(Unknown Source) at cli.System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(Unknown Source) at cli.System.Windows.Forms.Application$ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Unknown Source) at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoopInner(Unknown Source) at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoop(Unknown Source) at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun(Unknown Source) at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel(Unknown Source) at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source) at cli.Ch.Cyberduck.Ui.Controller.MainController.Main(Unknown Source)

comment:8 Changed on Nov 7, 2013 at 6:47:15 PM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:9 Changed on Nov 8, 2013 at 2:15:05 PM by chris nolan

As a reference, I am also seeing this behavior. I opened Ticket #7522 re: WinSSHD, so I downloaded the latest snapshot to test the fix.

When I upload a file, it appears to complete successfully after uploading 0 bytes. I enabled debugging and have attached the log.

Changed on Nov 8, 2013 at 2:16:07 PM by chris nolan

comment:10 Changed on Nov 8, 2013 at 2:51:40 PM by dkocher

Can you please try snapshot build 13924 and attach the debug log again.

Changed on Nov 8, 2013 at 3:05:05 PM by chris nolan

comment:11 Changed on Nov 8, 2013 at 3:06:11 PM by chris nolan

Attached. I also attempted to download a file, and it seems like I get the same behavior. Completed with 0 bytes.

The log should show me opening cyberduck, attempting to upload 2 files, then attempting to download 1 file, then closing cyberduck.

comment:12 Changed on Nov 8, 2013 at 3:32:31 PM by dkocher

The bug was introduced in r13885.

comment:13 Changed on Nov 8, 2013 at 3:37:03 PM by dkocher

#7578 closed as duplicate.

comment:14 Changed on Nov 8, 2013 at 3:45:27 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r13928.

comment:16 Changed on Nov 8, 2013 at 4:22:09 PM by dkocher

Please update to the latest snapshot build available.

comment:17 Changed on Nov 8, 2013 at 4:27:25 PM by chris nolan

Looks like uploads and downloads are working properly in Snapshot build 13933. Thanks!

comment:18 Changed on Nov 8, 2013 at 6:40:05 PM by patrices

I updated to r13933 and there is no change. I still cannot upload. The upload screen comes up and shows a successful upload, but still 0 of 0 files (none are actually uploaded).

Note: See TracTickets for help on using tickets.
swiss made software