Cyberduck Mountain Duck CLI

#7553 closed defect (duplicate)

Fails to launch after update from the Mac App Store

Reported by: sicruse Owned by: dkocher
Priority: high Milestone: 4.4.1
Component: appstore Version: 4.4
Severity: critical Keywords:
Cc: Architecture:
Platform: Mac OS X 10.9

Description (last modified by dkocher)

I have just updated CyberDuck from the Apple AppStore to version 4.4 and now the app will not launch.

“Cyberduck” is damaged and can’t be opened. Delete “Cyberduck” and download it again from the App Store.

Change History (12)

comment:1 Changed on Nov 6, 2013 at 8:38:27 AM by dkocher

  • Milestone set to 4.4.1
  • Owner set to dkocher
  • Priority changed from normal to high
  • Severity changed from normal to critical
  • Status changed from new to assigned
  • Summary changed from V4.4 fails to launch after update from the Apple AppStore to Fails to launch after update from the Mac App Store

comment:2 Changed on Nov 6, 2013 at 8:38:52 AM by dkocher

  • Description modified (diff)

comment:3 Changed on Nov 6, 2013 at 8:40:00 AM by dkocher

Report from another user.

Cyberduck(33479) deny network-bind /private/var/folders/ky/2nbt1qw904sgwrz2w7ldn10h0000gn/T/ch.sudo.cyberduck/.java_pid33479.tmp

Process:         Cyberduck [33479]
Path:            /Applications/Cyberduck.app/Contents/MacOS/Cyberduck
Load Address:    0x100000000
Identifier:      ch.sudo.cyberduck
Version:         13640 (4.4)
Code Type:       x86_64 (Native)
Parent Process:  launchd [200]

Date/Time:       2013-11-06 11:48:06.764 +0400
OS Version:      Mac OS X 10.9 (13A603)
Report Version:  8

Thread 0:
0   libsystem_kernel.dylib        	0x00007fff9269ce62 __bind + 10
1   libjvm.dylib                  	0x00000001018ef9ed AttachListener::pd_init() + 69
2   libjvm.dylib                  	0x00000001018ee5f6 attach_listener_thread_entry(JavaThread*, Thread*) + 46
3   libjvm.dylib                  	0x0000000101cc4ba5 JavaThread::thread_main_inner() + 155
4   libjvm.dylib                  	0x0000000101cc627f JavaThread::run() + 417
5   libjvm.dylib                  	0x0000000101bf2c95 java_start(Thread*) + 213
6   libsystem_pthread.dylib       	0x00007fff8d3e2899 _pthread_body + 138
7   libsystem_pthread.dylib       	0x00007fff8d3e272a _pthread_struct_init + 0
8   libsystem_pthread.dylib       	0x00007fff8d3e6fc9 thread_start + 13

Binary Images:
       0x101800000 -        0x101f04fff  libjvm.dylib (1) <93091e3b-d017-3842-8066-fd745c13a808> /Applications/Cyberduck.app/Contents/Resources/Java/Runtime.jre/Contents/Home//lib/server/libjvm.dylib
    0x7fff8d3e1000 -     0x7fff8d3e8ff7  libsystem_pthread.dylib (53.1.4) <ab498556-b555-310e-9041-f67ec9e00e2c> /usr/lib/system/libsystem_pthread.dylib
    0x7fff92688000 -     0x7fff926a4ff7  libsystem_kernel.dylib (2422.1.72) <d14913db-47f1-3591-8daf-d4b4ef5f8818> /usr/lib/system/libsystem_kernel.dylib

comment:4 Changed on Nov 6, 2013 at 2:02:42 PM by dkocher

#7555 closed as duplicate.

comment:5 Changed on Nov 6, 2013 at 2:50:24 PM by dkocher

  • Component changed from core to appstore

comment:6 Changed on Nov 6, 2013 at 2:51:00 PM by dkocher

Possibly related to #7557.

comment:7 follow-up: Changed on Nov 6, 2013 at 2:53:54 PM by dkocher

Can you open Terminal.app and post the output of the command

spctl -v --assess --type execute /Applications/Cyberduck.app/

comment:8 follow-up: Changed on Nov 6, 2013 at 3:49:28 PM by dkocher

Can you please try rebooting your computer and try again launching the application which will fix possible issues with storeagent that should load the receipt.

comment:9 in reply to: ↑ 7 Changed on Nov 6, 2013 at 4:25:04 PM by sicruse

Replying to dkocher:

Can you open Terminal.app and post the output of the command

spctl -v --assess --type execute /Applications/Cyberduck.app/

As requested:

$spctl -v --assess --type execute /Applications/Cyberduck.app/
/Applications/Cyberduck.app/: accepted
source=Mac App Store

comment:10 in reply to: ↑ 8 Changed on Nov 6, 2013 at 4:28:36 PM by sicruse

Replying to dkocher:

Can you please try rebooting your computer and try again launching the application which will fix possible issues with storeagent that should load the receipt.

Rebooting does not appear to resolve the launch issue.

comment:11 Changed on Nov 6, 2013 at 8:13:20 PM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Closing as duplicate for #7557.

comment:12 Changed on Nov 7, 2013 at 6:29:01 PM by dkocher

We have identified the cause to be any missing network interface available. The validation fails if no en0 network interface is available. Users can request a donation key at ​feedback@… who want to switch to the free version available from the website. The 4.4.1 update is currently pending review by Apple for the Mac App Store.

Note: See TracTickets for help on using tickets.
swiss made software