Cyberduck Mountain Duck CLI

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#7556 closed defect (fixed)

Listing directory failure with missing permission to read symlink target

Reported by: arjen van bochoven Owned by: dkocher
Priority: normal Milestone: 4.4.1
Component: sftp Version: 4.4
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.9

Description

When I create a symlink to a file in a directory that I don't have permissions to read, directory listing of the directory where the symlink is fails:

Permission denied (SSH_FX_PERMISSION_DENIED: The user does not have sufficient permissions to perform the operation.). Please contact your web hosting service provider for assistance.

If I create a symlink to a file that I don't have permissions for, directory listing succeeds.

I can reproduce this issue on Windows (7) and Mac OSX

Change History (4)

comment:1 Changed 5 years ago by dkocher

  • Component changed from core to sftp
  • Milestone set to 4.4.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed 5 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r13830.

comment:3 Changed 5 years ago by dkocher

  • Summary changed from Listing directory failed: caused by a symlink to Listing directory failure with missing permission to read symlink target

comment:4 Changed 5 years ago by dkocher

#7571 closed as duplicate.

Note: See TracTickets for help on using tickets.
swiss made software