Cyberduck Mountain Duck CLI

#7557 closed defect (fixed)

Exit with 173 without prompt for credentials to obtain valid receipt

Reported by: breckero Owned by: dkocher
Priority: high Milestone: 4.4.1
Component: appstore Version: 4.4
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by dkocher)

Hi Cyberduck-Team,

I cannot start Cyberduck anymore. Since the last update it crashes on startup. The log-File cyberduck.log does not exist in app data folder.

Please help, I need it for my next software deployment...

Best Regards

Oliver Brecker

Munich

05.11.13 09:06:41,469 sandboxd[130]: ([5640]) Cyberduck(5640) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid5640.tmp
05.11.13 09:06:45,168 WindowServer[85]: disable_update_timeout: UI updates were forcibly disabled by application "Cyberduck" for over 1.00 seconds. Server has re-enabled them.
05.11.13 09:06:46,092 Cyberduck[5640]: [background-1] FATAL ch.cyberduck.core.ProtocolFactory - Unknown protocol with identifier gd
05.11.13 09:06:46,151 WindowServer[85]: common_reenable_update: UI updates were finally reenabled by application "Cyberduck" after 1.98 seconds (server forcibly re-enabled them after 1.00 seconds)
05.11.13 09:06:50,642 Cyberduck[5640]: *** WARNING: -[NSImage compositeToPoint:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
05.11.13 09:06:50,642 Cyberduck[5640]: *** WARNING: -[NSImage compositeToPoint:fromRect:operation:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.
05.11.13 09:07:39,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:08:11,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:08:16,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:10:01,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:10:02,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:11:13,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:11:13,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:38:37,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:38:37,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:38:38,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:38:39,000 kernel[0]: Cyberduck[5640] Unable to quarantine: 1
05.11.13 09:59:44,608 WindowServer[85]: CGError post_notification(const CGSNotificationType, void *const, const size_t, const bool, const CGSRealTimeDelta, const int, const CGSConnectionID *const, const pid_t): Timed out 1.000 second wait for reply from "Cyberduck" for synchronous notification type 102 (kCGSDisplayWillSleep) (CID 0x2745b, PID 5640)
06.11.13 14:53:37,000 kernel[0]: Sandbox: Cyberduck(7707) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7707.tmp
06.11.13 14:53:40,053 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58112[7707]) Exited with code: 173
06.11.13 14:53:49,444 xpcd[183]: restored permissions (100600 -> 100700) on /Users/oliver/Library/Containers/ch.sudo.cyberduck/Container.plist
06.11.13 14:53:49,000 kernel[0]: Sandbox: Cyberduck(7712) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7712.tmp
06.11.13 14:53:51,464 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58112[7712]) Exited with code: 173
06.11.13 15:02:07,000 kernel[0]: Sandbox: Cyberduck(7772) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7772.tmp
06.11.13 15:02:09,947 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7772]) Exited with code: 173
06.11.13 15:02:31,000 kernel[0]: Sandbox: Cyberduck(7778) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7778.tmp
06.11.13 15:02:33,506 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7778]) Exited with code: 173
06.11.13 15:04:19,000 kernel[0]: Sandbox: Cyberduck(7787) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7787.tmp
06.11.13 15:04:21,369 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7787]) Exited with code: 173
06.11.13 15:08:43,308 xpcd[183]: restored permissions (100600 -> 100700) on /Users/oliver/Library/Containers/ch.sudo.cyberduck/Container.plist
06.11.13 15:08:43,000 kernel[0]: Sandbox: Cyberduck(7806) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7806.tmp
06.11.13 15:08:45,257 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7806]) Exited with code: 173
06.11.13 15:12:52,000 kernel[0]: Sandbox: Cyberduck(7818) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7818.tmp
06.11.13 15:12:53,907 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7818]) Exited with code: 173
06.11.13 15:16:34,000 kernel[0]: Sandbox: Cyberduck(7840) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7840.tmp
06.11.13 15:16:36,739 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7840]) Exited with code: 173
06.11.13 15:19:04,000 kernel[0]: Sandbox: Cyberduck(7846) deny network-bind /private/var/folders/08/shgnq60n6rl28ld7mg5ff_yc0000gn/T/ch.sudo.cyberduck/.java_pid7846.tmp
06.11.13 15:19:06,553 com.apple.launchd.peruser.501[165]: (ch.sudo.cyberduck.58640[7846]) Exited with code: 173

Attachments (1)

appstore.tiff (70.8 KB) - added by breckero on Nov 6, 2013 at 3:57:13 PM.

Download all attachments as: .zip

Change History (28)

comment:1 Changed on Nov 6, 2013 at 2:45:46 PM by dkocher

  • Description modified (diff)
  • Milestone set to 4.4.1
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Nov 6, 2013 at 2:48:29 PM by dkocher

If the application exits with 173 that indicates that no Mac App Store receipt was found. It should trigger the Mac App Store login prompt to appear to verify your purchase.

comment:3 Changed on Nov 6, 2013 at 2:50:09 PM by dkocher

  • Summary changed from App (from AppStore) crashes on startup to Exit with 173 without prompt for credentials to obtain valid receipt

comment:4 Changed on Nov 6, 2013 at 2:53:58 PM by dkocher

  • Component changed from core to appstore

Can you open Terminal.app and post the output of the command

spctl -v --assess --type execute /Applications/Cyberduck.app/

comment:5 Changed on Nov 6, 2013 at 3:36:03 PM by breckero

oliver$ spctl -v --assess --type execute /Applications/Cyberduck.app/
/Applications/Cyberduck.app/: accepted
source=Mac App Store
oliver$

Last edited on Nov 6, 2013 at 3:44:30 PM by dkocher (previous) (diff)

comment:6 Changed on Nov 6, 2013 at 3:48:32 PM by dkocher

Looks all fine then. Can you please try rebooting your computer and try again launching the application which will fix possible issues with storeagent that should load the receipt.

Changed on Nov 6, 2013 at 3:57:13 PM by breckero

comment:7 Changed on Nov 6, 2013 at 3:57:47 PM by breckero

rebooted and getting the same error.

comment:8 Changed on Nov 6, 2013 at 5:06:07 PM by dkocher

#7558 closed as duplicate.

comment:9 Changed on Nov 6, 2013 at 5:59:42 PM by dkocher

#7559 closed as duplicate.

comment:10 Changed on Nov 6, 2013 at 8:00:57 PM by dkocher

#7562 closed as duplicate.

comment:11 Changed on Nov 6, 2013 at 8:13:06 PM by dkocher

#7553 closed as duplicate.

“Cyberduck” is damaged and can’t be opened. Delete “Cyberduck” and download it again from the App Store.

comment:12 Changed on Nov 6, 2013 at 8:13:28 PM by dkocher

  • Platform set to Mac OS X 10.9

comment:13 Changed on Nov 6, 2013 at 9:54:35 PM by dkocher

#7564 closed as duplicate.

comment:14 Changed on Nov 6, 2013 at 9:55:19 PM by dkocher

As a workaround until we have found the cause of this issue, please use the version available from https://update.cyberduck.ch/Cyberduck-4.4.zip.

comment:15 Changed on Nov 6, 2013 at 11:34:21 PM by dkocher

Can you open Terminal.app and post the output of the command

ls -l /Applications/Cyberduck.app/Contents/_MASReceipt/

comment:16 Changed on Nov 7, 2013 at 8:00:39 AM by breckero

oliver$ ls -l /Applications/Cyberduck.app/Contents/_MASReceipt/
total 16
-rw-r--r--  1 root  wheel  4740  6 Nov 15:01 receipt
Contents oliver$
Last edited on Nov 7, 2013 at 8:24:04 AM by dkocher (previous) (diff)

comment:17 Changed on Nov 7, 2013 at 8:32:53 AM by dkocher

#7566, #7567, #7569 closed as duplicates.

comment:18 Changed on Nov 7, 2013 at 8:58:24 AM by dkocher

Can you please send the receipt file (Choose Show Package Contents on Cyberduck.app and navigate to Contents/_MASReceipt/ to feedback@….

comment:19 Changed on Nov 7, 2013 at 8:59:08 AM by dkocher

We haven't heard back from Apple regarding this issue but as it potentially affects a large number of users we will try to push an update with disabled verification through expedited review today.

comment:20 Changed on Nov 7, 2013 at 8:59:55 AM by dkocher

Users can request a donation key at feedback@… who want to switch to the free version available from the website.

comment:21 Changed on Nov 7, 2013 at 9:18:54 AM by breckero

sent receipt file to feedback@, good luck withit ;-)

comment:22 follow-up: Changed on Nov 7, 2013 at 10:18:14 AM by dkocher

We have identified the cause to be any missing network interface available. The validation fails if no en0 network interface is available. Can you check to make sure either WiFi is on or you have Ethernet plugged in and the application should launch.

comment:23 Changed on Nov 7, 2013 at 10:19:27 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r13856.

comment:24 Changed on Nov 7, 2013 at 6:27:33 PM by dkocher

#7574, #7577 closed as duplicate.

comment:25 Changed on Nov 7, 2013 at 6:27:42 PM by dkocher

The 4.4.1 update is currently pending review by Apple for the Mac App Store.

comment:26 in reply to: ↑ 22 Changed on Nov 9, 2013 at 4:40:21 AM by guybrush

Replying to dkocher:

We have identified the cause to be any missing network interface available. The validation fails if no en0 network interface is available. Can you check to make sure either WiFi is on or you have Ethernet plugged in and the application should launch.

Since it's not clear if the fix above will resolve the problem on my system, I thought I should mention that I have confirmed my Wi-Fi is on and I have a connection, but I still get the "Cyberduck is damaged" error message when launching the App Store version of 4.4. I have verified I have access to FTP ports and nothing weird is happening with firewalls. I am running Mavericks 10.9 with all system updates. Possibly it's important that the new Thunderbolt Bridge network interface is now available (though not connected); likewise I had Firewire, Bluetooth PAN and Ethernet interfaces installed but unavailable. Removing all unconnected interfaces did not resolve the problem - Cyberduck still produced the same error message, though noticeably quicker than before. Note I have also tried reinstalling Cyberduck from the App Store.

Hope this information is useful!

comment:27 Changed on Nov 12, 2013 at 8:48:41 AM by dkocher

We are sorry it takes so long to make the update available. We had a fix submited to Apple on day zero but although we requested an expedited review on 7 Nov 2013 we still see no progress.

Users can request a donation key at feedback@… who want to switch to the free version available from the website.

Note: See TracTickets for help on using tickets.
swiss made software