Cyberduck Mountain Duck CLI

#7571 closed defect (duplicate)

Cannot overwrite file via sFTP

Reported by: bastiankroll Owned by: dkocher
Priority: normal Milestone: 4.4.1
Component: sftp Version: 4.4
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Suddenly (but not every time), I get an error while overwriting an existing file on the remote server. Connection via sFTP established, drag the file on the window, after klick on "overwrite" in the warning dialog I´m getting this message:

Verbindung fehlgeschlagen
The server sent an invalid id field:

SSH_FXP_REALPATH
SSH_FXP_NAME
/srv/www/xxxx/xxx.txt
SSH_FXP_REALPATH
SSH_FXP_NAME
/srv/www/xxxx/xxx.txt
SSH_FXP_OPENDIR
SSH_FXP_HANDLE
SSH_FXP_READDIR
SSH_FXP_REALPATH
SSH_FXP_SYMLINK

After canceling this action, I cannot list the folder content: Ordnerinhalt anzeigen fehlgeschlagen: Illegal sftp packet len 439317362.

Only reconnecting is solving this.

In the previous version (3.x) I don´t have this problems via sFTP

Change History (4)

comment:1 Changed on Nov 7, 2013 at 11:24:53 AM by dkocher

  • Component changed from core to sftp
  • Description modified (diff)
  • Owner set to dkocher

comment:2 follow-up: Changed on Nov 7, 2013 at 11:56:38 AM by dkocher

Can you reproduce this issue with the latest snapshot build available?

comment:3 in reply to: ↑ 2 Changed on Nov 7, 2013 at 12:12:04 PM by bastiankroll

Replying to dkocher:

Can you reproduce this issue with the latest snapshot build available?

Build 13869 seems to fix this…thanks, you can close this issue

Btw: On my Mac (10.7.5) the main-menu "CyberDuck" in the menu-bar seems to be broken. Instead off "donatian" I get the entry "donation{file:FinderLocal{…"

comment:4 Changed on Nov 7, 2013 at 12:13:43 PM by dkocher

  • Milestone set to 4.4.1
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #7556.

Note: See TracTickets for help on using tickets.
swiss made software