Cyberduck Mountain Duck CLI

#7587 closed defect (worksforme)

Public key login fails

Reported by: garyaj Owned by: dkocher
Priority: normal Milestone: 4.4.1
Component: sftp Version: 4.4
Severity: normal Keywords: sftp, PKI, fail
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by dkocher)

sftp PKI login fails, works with Transmit and Mac OS X commandline.

I've set up .ssh/config for my server (nfs.sitesuite.net). I can use ssh, scp and sftp from Mac OS X commandline. I can use Transmit using exactly the same credentials and options.

Why doesn't Cyberduck log me in? I'll continue to use Transmit but I much prefer Cyberduck.

Attachments (1)

Screen Shot 2013-11-10 at 2.45.28 pm.png (46.8 KB) - added by garyaj on Nov 10, 2013 at 3:45:59 AM.

Download all attachments as: .zip

Change History (8)

comment:1 Changed on Nov 11, 2013 at 3:43:03 PM by dkocher

  • Component changed from core to sftp
  • Description modified (diff)
  • Milestone set to 4.4.1
  • Owner set to dkocher
  • Summary changed from sftp PKI login fails, works with Transmit and Mac OS X commandline. to Public key login fails

comment:2 Changed on Nov 12, 2013 at 7:23:55 PM by dkocher

Please try to the latest snapshot build available. Possible duplicate of #7536.

comment:3 follow-up: Changed on Nov 12, 2013 at 7:51:12 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed

comment:4 in reply to: ↑ 3 Changed on Nov 13, 2013 at 12:18:11 AM by garyaj

Replying to dkocher: Installed latest snapshot build as suggested. NO CHANGE! This is not a duplicate of #7536. #7536 displays a different response. Please reopen this ticket and FIX the problem.

comment:5 Changed on Nov 13, 2013 at 4:59:01 AM by dkocher

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:6 Changed on Nov 13, 2013 at 9:21:59 AM by dkocher

I am not aware and cannot replicate issues with public key authentication. Is it possible to get a temporary test account on your server with the same setup?

comment:7 Changed on Nov 14, 2013 at 1:00:12 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software