Cyberduck Mountain Duck CLI

#7592 closed defect (worksforme)

Upload fails with "Invalid argument" error

Reported by: andreasauwaerter Owned by: dkocher
Priority: normal Milestone: 4.4.2
Component: sftp Version: 4.4
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by dkocher)

Hi, i am not able to transfer files to our sftp server as I did before as usual routine. Cyberduck stops

11.11.13 09:31:11,635 Cyberduck[570]: [main] ERROR org.rococoa.callback - Exception calling method for selector tableView:willDisplayCell:forTableColumn:row:

java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor41.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.GeneratedMethodAccessor14.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:449)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:479)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:334)
	at com.sun.jna.Function.invoke(Function.java:278)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:232)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:156)
Caused by: java.lang.IndexOutOfBoundsException: Index: 27, Size: 27
	at java.util.ArrayList.rangeCheck(ArrayList.java:635)
	at java.util.ArrayList.get(ArrayList.java:411)
	at ch.cyberduck.ui.cocoa.BrowserController$11.tableView_willDisplayCell_forTableColumn_row(BrowserController.java:1410)
	... 24 more

Attachments (4)

Bildschirmfoto 2013-11-11 um 09.48.17.png (30.6 KB) - added by andreasauwaerter on Nov 11, 2013 at 8:49:04 AM.
Screenshot error message
Bildschirmfoto 2013-11-11 um 17.50.13.png (50.1 KB) - added by andreasauwaerter on Nov 11, 2013 at 5:40:00 PM.
Screenshot with 4.4.1
Bildschirmfoto 2013-11-11 um 18.07.27.png (50.6 KB) - added by andreasauwaerter on Nov 11, 2013 at 5:40:20 PM.
Screenshot with 4.4.1 again!
All_Cyberduck_messages_11_2013.log (38.8 KB) - added by andreasauwaerter on Nov 11, 2013 at 5:40:42 PM.
All Logs from Konsole.

Download all attachments as: .zip

Change History (11)

Changed on Nov 11, 2013 at 8:49:04 AM by andreasauwaerter

Screenshot error message

comment:1 Changed on Nov 11, 2013 at 9:37:51 AM by dkocher

  • Description modified (diff)
  • Milestone set to 4.4.1

comment:2 Changed on Nov 11, 2013 at 3:42:08 PM by dkocher

Can you reproduce this issue with the latest snapshot build available?

comment:3 Changed on Nov 11, 2013 at 3:42:28 PM by dkocher

  • Summary changed from Mavericks and cyberduck 4.4 - SFTP upload error to IndexOutOfBoundsException in browser list on upload

Changed on Nov 11, 2013 at 5:40:00 PM by andreasauwaerter

Screenshot with 4.4.1

Changed on Nov 11, 2013 at 5:40:20 PM by andreasauwaerter

Screenshot with 4.4.1 again!

Changed on Nov 11, 2013 at 5:40:42 PM by andreasauwaerter

All Logs from Konsole.

comment:4 Changed on Nov 11, 2013 at 5:41:54 PM by andreasauwaerter

Hi - wondering - I now bought cyberduck as I needed to upload a file on a mac not running Mavericks Loved to pay the price. Anyhow - automaticly my mavericks account was unlocked ;-) But i downloaded tha latest (nightly built) manually and started.

Anyhow the problem persited and i will attach now every .log with cyberduck in it.

Transfer Log: Log

SSH_FXP_READDIR
SSH_FXP_STATUS
SSH_FXP_CLOSE
SSH_FXP_STATUS
SSH_FXP_REALPATH
SSH_FXP_STATUS
No such file
SSH_FXP_REALPATH
SSH_FXP_STATUS
No such file
SSH_FXP_OPEN
SSH_FXP_HANDLE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_WRITE
SSH_FXP_STATUS
SSH_FXP_STATUS
SSH_FXP_STATUS
SSH_FXP_STATUS
SSH_FXP_STATUS
SSH_FXP_STATUS
SSH_FXP_CLOSE

Last edited on Nov 12, 2013 at 12:25:49 PM by dkocher (previous) (diff)

comment:5 Changed on Nov 12, 2013 at 2:11:46 PM by dkocher

Looks like a different interoperability issue now. Can you try disabling Preferences → Transfers → General → Uploads → Upload with Temporary filename.

comment:6 Changed on Nov 13, 2013 at 2:18:22 PM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher
  • Summary changed from IndexOutOfBoundsException in browser list on upload to Upload fails with "Invalid argument" error

comment:7 Changed on Nov 19, 2013 at 8:13:24 PM by dkocher

  • Milestone set to 4.4.2
  • Resolution set to worksforme
  • Status changed from new to closed

Closing awaiting feedback.

Note: See TracTickets for help on using tickets.
swiss made software