Cyberduck Mountain Duck CLI

#7668 closed defect (worksforme)

S3 transfer progress is not updated

Reported by: emerson farrugia Owned by: dkocher
Priority: high Milestone:
Component: interface Version: 4.4.3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

I'm uploading some directories to S3, one at a time. The Transfers window shows the transfers, and the progress bar and speed and so on for the first few directories. From about the fifth transfer onwards, the progress isn't updated, and the transfer looks like it's just stalled.

But it's not. If I scroll the transfers window and make the list bounce-back, the progress is updated and then freezes again. I've attached a video in case that helps.

Attachments (1)

cybderduckprogress.mov (401.0 KB) - added by emerson farrugia on Dec 8, 2013 at 12:36:57 PM.
screen capture showing bounce behaviour

Download all attachments as: .zip

Change History (3)

Changed on Dec 8, 2013 at 12:36:57 PM by emerson farrugia

screen capture showing bounce behaviour

comment:1 Changed on Jan 21, 2014 at 12:16:20 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the issue on my installation.

comment:2 Changed on Sep 9, 2014 at 7:01:14 AM by steve tompkins-macqueen

First sorry for the spelling I am dyslex......

Version 4.5.2

I have the some problem on Yosemite (I understand that OS X 10.10 Yosemite is in beta and you may not have had time to address any updates to code). But I see from this ticket that the problem seems to be in OS X 10.9 as well.

To try and clarify. When you drag a file from a FTP server to a Folder on the local machine (as you know) a "Transfers" window opens that shows the "File name" a "Progress Bar" a "indercator light (green for compleat)" and some text showing "how much is to be tranfared and how much has been..."

None of the items that should change/update over time do change unless there is some actitivity in the window. It would appear the the windows information is only active when the window is active and being re-drawn. This may be a bug in OS X so I will send this to Apple as well but it also may just be an atribute that can be set in interface builder.

I hope this information helps.

Note: See TracTickets for help on using tickets.
swiss made software