Cyberduck Mountain Duck CLI

#7720 closed defect (worksforme)

Unable to set custom keyboard shortcuts

Reported by: cwd Owned by:
Priority: normal Milestone:
Component: core Version: 4.4.3
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.9

Description (last modified by cwd)

I've tried to use the Preferences dialog in OS X to set custom keyboard shortcuts for CyberDuck - a few of them being:

New Bookmark
Disconnect
Edit Bookmark

"New Bookmark" works but "Disconnect" and "Edit Bookmark" are not working very well. In the menu the old keyboard shot disappeared but the new keyboard shotcut does not show up - and the assigned keyboard shortcut ( for example, Disconnect ) just does what it previously did - Duplicate.

https://trac.cyberduck.io/raw-attachment/ticket/7720/keyboard-prefs.png https://trac.cyberduck.io/raw-attachment/ticket/7720/screen.png

Attachments (2)

keyboard-prefs.png (117.6 KB) - added by cwd on Jan 6, 2014 at 4:01:44 PM.
preferences for keyboard shortcuts
screen.png (29.1 KB) - added by cwd on Jan 6, 2014 at 4:02:24 PM.
how it shows up in the menu ( no shortcut showing )

Download all attachments as: .zip

Change History (8)

Changed on Jan 6, 2014 at 4:01:44 PM by cwd

preferences for keyboard shortcuts

Changed on Jan 6, 2014 at 4:02:24 PM by cwd

how it shows up in the menu ( no shortcut showing )

comment:1 Changed on Jan 6, 2014 at 4:03:49 PM by cwd

  • Description modified (diff)

comment:2 Changed on Jan 6, 2014 at 4:47:48 PM by dkocher

  • Summary changed from unable to set custom keyboard shortcuts on Mac OS X to Unable to set custom keyboard shortcuts

comment:3 Changed on Jan 21, 2014 at 12:13:04 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue. Make sure you also assign a new shortcut for Info (⌘-I) and New Browser (⌘-N) to replace the default shortcuts.

comment:4 Changed on Jan 21, 2014 at 12:51:11 PM by cwd

At times I could get it to show up in the menu bar but the keyboard shortcut key would not actually work. I think you may have got the keyboard shortcuts to show up in the menu bar but were you actually able to use them to open the info window, and to toggle the creation of a new site? Another one I had trouble with was "disconnect" which I attempted to assign to Cmd+J

comment:5 follow-up: Changed on Jan 21, 2014 at 1:06:31 PM by cwd

Ok - just tested again and seems like if I do make sure the existing shortcut has been replaced, then I can assign the new one. But I also have to restart the Cyberduck app to make the changes take effect.

http://img841.imageshack.us/img841/5572/1imc.png

I would just like to note that both of these things are different from the default way all other apps ( that I've seen so far ) manage keyboard shortcuts. In other apps:

  • You don't have to set a replacement keyboard shortcut if you assign a keyboard shortcut to a different menu item
  • You don't have to restart the app for keyboard changes to show up if you assign a default shortcut key a different shortcut and then assign the previously used shortcut key to a new, non-standard function.

So, it works, but it seems like Cybderduck handles keyboard shortcuts in a non-standard way which was leading me to think it was broken.

Thanks for checking into it.

comment:6 in reply to: ↑ 5 Changed on Jan 21, 2014 at 1:49:21 PM by dkocher

Replying to cwd:

So, it works, but it seems like Cybderduck handles keyboard shortcuts in a non-standard way which was leading me to think it was broken.

I am not aware we have any custom handling of keyboard shortcuts but rely on the system frameworks.

Note: See TracTickets for help on using tickets.
swiss made software