Cyberduck Mountain Duck CLI

#7762 closed defect (thirdparty)

List of content not showing up

Reported by: anykeyit Owned by: dkocher
Priority: normal Milestone: 4.4.4
Component: webdav Version: 4.4.3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

When I connect via WebDAV (Http/SSL) to a Rumpusserver, I'm authenticated but the list of files isn't showing up. Everything works fine under 10.7 and 10.8 but not on 10.9 and not on Win 8.1 (Same behavior)

Attachments (2)

Change History (9)

comment:1 follow-up: Changed on Jan 29, 2014 at 3:38:58 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 Changed on Jan 29, 2014 at 3:39:18 PM by dkocher

  • Component changed from core to webdav
  • Milestone set to 4.4.4
  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 in reply to: ↑ 1 ; follow-up: Changed on Jan 29, 2014 at 4:06:13 PM by anykeyit

Replying to dkocher:

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

Unfortunately there are no entries related to Cyberduck in the Console.

Now I found out on OS 10.9.1 when I wait, then I get the message: "Login erfolgreich" but no list of files "Verbindung fehlgeschlagen". Now I can klick on "Aktualisieren" and get the list.

But I see only my Files in a correct way, not the folders.

Here is the login: schulwolke.ch test yEdnJv49

comment:4 Changed on Jan 29, 2014 at 4:26:47 PM by dkocher

The initial empty directory listing is caused by a timeout waiting for the server response for the initial PROPFIND request.

comment:5 Changed on Jan 29, 2014 at 4:27:04 PM by dkocher

Fix retry of mount action to discard cached empty listing in r14273.

comment:6 Changed on Jan 29, 2014 at 4:29:07 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from assigned to closed

The server does not send a resourcetype for the files. Therefore we default to treating the resources as files instead of directories. Folders should be marked as a collection. Please report this issue to the server vendor.

comment:7 in reply to: ↑ 3 Changed on Jan 29, 2014 at 4:30:10 PM by dkocher

Replying to anykeyit:

Replying to dkocher:

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

Unfortunately there are no entries related to Cyberduck in the Console.

Now I found out on OS 10.9.1 when I wait, then I get the message: "Login erfolgreich" but no list of files "Verbindung fehlgeschlagen". Now I can klick on "Aktualisieren" and get the list.

But I see only my Files in a correct way, not the folders.

Here is the login: schulwolke.ch test yEdnJv49

Thanks for the test account which eases debugging the issue a lot. You can remove the account again.

Note: See TracTickets for help on using tickets.
swiss made software