Cyberduck Mountain Duck CLI

#7778 closed defect (worksforme)

Temporary files created during transfers are not cleaned up automatically

Reported by: Knocks Owned by: yla
Priority: high Milestone: 4.4.4
Component: core Version: 7.0.1
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 10

Description

I choose to display hidden files in Windows by default. Each time a transfer is initiated in Cyberduck, a temporary file is created on my Desktop. That file is not cleaned up even after the transfer is finished until I manually hit F5. Any way to address this?

Change History (12)

comment:1 Changed on Feb 7, 2014 at 2:06:13 PM by dkocher

  • Milestone set to 4.4.4
  • Owner set to yla

comment:2 Changed on Feb 7, 2014 at 11:10:01 PM by Knocks

I would like to suggest to keep temporary files off the Desktop completely, because they interfere with the placement of other icons. Perhaps temporary files can be stored either in the Cyberduck directory or one of the Windows temp directories, and the user can be given a choice.

comment:3 Changed on Feb 18, 2014 at 3:12:37 PM by ccharbonneau

I would like to also support keeping all temporary files away from the desktop or any non-temporary folder.

comment:4 Changed on Mar 26, 2014 at 1:54:50 PM by dkocher

#7770 closed as duplicate.

comment:5 Changed on Apr 3, 2014 at 11:57:31 AM by yla

  • Resolution set to wontfix
  • Status changed from new to closed

Windows drag&drop mechanics does not allow source application of drag&drop operation to easily find out where the files are dropped. That why we have a filesystem watcher and create a temporary file at the drop location to find out the drop folder. There is no easy way to change this. A shell extension might be a solution but needs a major refactoring.

comment:6 follow-up: Changed on Apr 3, 2014 at 6:41:58 PM by Knocks

I don't understand the comment by yla. Cyberduck creates a temporary file during a transfer, and the temporary file remains there even after Cyberduck is closed. That's not normal behavior. If you know where the temp file is created, then you know where to remove it from.

Last edited on Apr 3, 2014 at 6:42:14 PM by Knocks (previous) (diff)

comment:7 in reply to: ↑ 6 Changed on Apr 3, 2014 at 6:48:25 PM by ccharbonneau

Replying to Knocks:

I don't understand the comment by yla. Cyberduck creates a temporary file during a transfer, and the temporary file remains there even after Cyberduck is closed. That's not normal behavior. If you know where the temp file is created, then you know where to remove it from.

I think yla might be a bit confused. The actual issue is not that the file is not removed, but that windows seems to think it is there until there is a manual refresh. It might be a windows problem, but I suspect there might a way to fix it within Cyberduck.

comment:8 Changed on Apr 3, 2014 at 7:42:54 PM by dkocher

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:9 Changed on Apr 4, 2014 at 2:22:18 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

We cannot reproduce the issue that the Desktop in Explorer must be manually refreshed.

comment:10 Changed on Apr 4, 2014 at 6:53:08 PM by Knocks

dkocher: Are you using Windows 8.1 x64?

comment:11 Changed on Jul 5, 2019 at 1:29:39 PM by korggrodno

  • Platform changed from Windows 8 to Windows 10
  • Version changed from 4.4.3 to 7.0.1

I'm using windows 10 x64
When I use the "duck --longlist" key temp files are created
When I use the "duck --delete" key temp files are created
When I use the "duck --upload" key temp files are created
Temporary files are not automatically deleted when the program cyberduck is finished
After one night of work 5GB of temporary files were formed.
I Have to remove them manually.
Because the files are very shallow the deletion takes a very long time.
I hope this can be fixed somehow?

Last edited on Jul 5, 2019 at 1:30:18 PM by korggrodno (previous) (diff)

comment:12 Changed on Jul 5, 2019 at 1:31:12 PM by korggrodno

  • Priority changed from normal to high
Note: See TracTickets for help on using tickets.
swiss made software