Cyberduck Mountain Duck CLI

#7784 closed defect (fixed)

Files are uploaded partially with text cut off in the middle of the file

Reported by: Knocks Owned by: dkocher
Priority: high Milestone: 4.4.4
Component: ftp Version: 4.4.3
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Windows 8

Description (last modified by dkocher)

This is a persistent issue tested with several HTML files of different sizes. I have lost my work several times now.

It happens under two different scenarios:

  • 1) remote HTML files are worked on in Notepad++, you click save, and the file is not uploaded completely, so your work is gone
  • 2) local HTML files are worked in in Notepad++, saved, and uploaded with Cyberduck via drag and drop. When downloaded back from the server, the files are again incomplete.

Change History (15)

comment:1 Changed on Feb 10, 2014 at 7:25:46 PM by dkocher

  • Milestone set to 4.4.4

What protocol do you use to connect to the server?

comment:2 Changed on Feb 10, 2014 at 7:27:33 PM by Knocks

FTP. I have just discovered that if I disconnect from the server, then reconnect and refresh the file list, the files are no longer incomplete.

comment:3 Changed on Feb 10, 2014 at 7:48:03 PM by dkocher

  • Component changed from core to ftp
  • Owner set to dkocher

comment:4 Changed on Feb 19, 2014 at 1:36:55 AM by Scientifik

Just opened a ticket for this. My Downloads are loosing the last 10% of their code. Have you experienced this as well? I am connecting via SFTP.

Last edited on Feb 19, 2014 at 1:37:28 AM by Scientifik (previous) (diff)

comment:5 Changed on Feb 19, 2014 at 8:21:12 PM by dkocher

  • Summary changed from HTML files are uploaded partially with text cut off in the middle of the file to Files are uploaded partially with text cut off in the middle of the file

#7798 closed as duplicate.

comment:6 follow-up: Changed on Feb 22, 2014 at 4:45:41 PM by mathcolo

Also seeing this on OS X 10.9.1 (Cyberduck 4.4.3 build 14140) with SFTP. It's very frustrating...colleagues of mine have had to restore files from server backups because of mistakenly overwriting incomplete data :(

comment:7 in reply to: ↑ 6 Changed on Feb 22, 2014 at 4:50:35 PM by Scientifik

Replying to mathcolo: I thought it may have had to do with Windows 7, a PC CD problem! I feel your pain. I was responsible for the new site going down at the design firm where I work when the team realized it was CyberDuck...

comment:8 Changed on Feb 22, 2014 at 5:31:14 PM by dkocher

  • Status changed from new to assigned

comment:9 follow-up: Changed on Mar 2, 2014 at 10:17:07 AM by dkocher

Can you replicate this issue when downloading the file manually (without choosing to Edit), verify its contents and upload it again.

comment:10 in reply to: ↑ 9 ; follow-up: Changed on Mar 2, 2014 at 10:23:20 AM by dkocher

Replying to dkocher:

Can you replicate this issue when downloading the file manually (without choosing to Edit), verify its contents and upload it again.

I can reproduce the issue.

comment:11 in reply to: ↑ 10 Changed on Mar 2, 2014 at 7:03:44 PM by mathcolo

Replying to dkocher:

I can reproduce the issue.

I believe I've seen it happen when doing download and Edit...both ways.

comment:12 Changed on Mar 3, 2014 at 3:30:04 PM by dkocher

#7777 closed as duplicate.

comment:13 Changed on Mar 26, 2014 at 11:32:35 AM by dkocher

  • Description modified (diff)

comment:14 Changed on Apr 4, 2014 at 1:48:57 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r14190.

comment:15 Changed on Apr 4, 2014 at 1:49:07 PM by dkocher

Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software