Cyberduck Mountain Duck CLI

#7815 closed defect (fixed)

Transfer rate and time remaining estimate inaccurate on resumed transfers

Reported by: jg3 Owned by: dkocher
Priority: normal Milestone: 4.4.4
Component: core Version: 4.4.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

When resuming downloads, the transfer rate (and accordingly, the remaining time estimate) is calculated incorrectly. For example:

Assume 10MB file.

5MB was previously downloaded.

DL is resumed.

At first, the tx rate is astronomically high and the estimated remaining time shows just a few seconds. It looks like the rate/time calculation is thinking that the first 5MB were downloaded instantaneously.

Suppose it takes 1 minute to DL the next 1MB. Now perhaps the rate would show 102.4KB/s (i.e. 6MB in 1 minute) and estimate less than 1 minute left (to DL the remaining 4MB) when in fact the rate has been 17KB/s (1MB in 1 minute) and it should be 4 minutes remaining.

In other words, I think the calculation is taking into account the previously-downloaded portion, which throws things off. It would be much more helpful if only the size remaining of the file since "resume" were taken into account - then we could have more accurate time (and transfer rate) estimates.

Change History (4)

comment:1 Changed on Mar 11, 2014 at 5:00:00 PM by dkocher

  • Milestone set to 4.4.4
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Tx rate and time remaining estimate inaccurate on resumed transfers to Transfer rate and time remaining estimate inaccurate on resumed transfers

comment:2 Changed on Mar 20, 2014 at 7:53:57 PM by michael krasnow

I can confirm this is still an issue as of build 14391

comment:3 Changed on Mar 21, 2014 at 3:21:54 PM by dkocher

  • Milestone changed from 4.4.4 to 4.5

comment:4 Changed on Apr 7, 2014 at 10:48:04 AM by dkocher

  • Milestone changed from 4.5 to 4.4.4
  • Resolution set to fixed
  • Status changed from assigned to closed

In r14451.

Note: See TracTickets for help on using tickets.
swiss made software