Cyberduck Mountain Duck CLI

#7834 closed defect (fixed)

Crashes after Preferences selected

Reported by: raybengen Owned by: dkocher
Priority: highest Milestone: 4.4.4
Component: core Version: 4.4.3
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

After deleting the app and reinstalling, when selecting Preferences, the app gobbles up ALL available memory and then hangs.

Attachments (4)

system.log (797.6 KB) - added by raybengen on Mar 25, 2014 at 2:46:03 AM.
system.log
ch.sudo.cyberduck.plist (9.3 KB) - added by raybengen on Mar 25, 2014 at 2:46:43 AM.
plist
Cyberduck_2014-03-25-160205_Mikaels-MacBook-Pro.crash (140.7 KB) - added by mik b on Mar 26, 2014 at 3:07:18 PM.
SelectPrefWhenConnected
Cyberduck.crash (1.4 MB) - added by raybengen on Mar 26, 2014 at 3:20:43 PM.
pasted file from crash report

Change History (18)

comment:1 Changed on Mar 4, 2014 at 1:42:35 PM by raybengen

Clicked too early..

Version 4.4.3 (14140)

comment:2 Changed on Mar 6, 2014 at 11:25:03 PM by raybengen

Hi. Can I get some help with this please ? It's not because I'm a paying customer so much as I'm blocked from using the product which I like very much.

--Ray

comment:3 Changed on Mar 24, 2014 at 11:00:33 AM by dkocher

  • Milestone set to 4.4.4
  • Owner set to dkocher
  • Status changed from new to assigned

Can you find any related output in the system.log (/Applications/Utilities/Console.app)? Please attach the file ~/Library/Preferences/ch.sudo.cyberduck.plist to this ticket. Moving it to the Trash will possibly resolve this issue.

Changed on Mar 25, 2014 at 2:46:03 AM by raybengen

system.log

Changed on Mar 25, 2014 at 2:46:43 AM by raybengen

plist

comment:4 Changed on Mar 25, 2014 at 2:47:13 AM by raybengen

Attached files as requested. Also, the move to .Trash didn't help.

comment:5 Changed on Mar 25, 2014 at 9:41:41 PM by mik b

I can report I have a hang when I select preferences as well, but only when I'm already connected (SSH-sftp). I can go to the prefs before I connect without a hang.

Last edited on Mar 25, 2014 at 9:42:31 PM by mik b (previous) (diff)

comment:6 Changed on Mar 26, 2014 at 11:35:01 AM by dkocher

Please attach the file /Library/Logs/DiagnosticReports/Cyberduck_2014-03-24-222840_rays-MacBook-Pro-3.hang.

Changed on Mar 26, 2014 at 3:07:18 PM by mik b

SelectPrefWhenConnected

comment:7 follow-up: Changed on Mar 26, 2014 at 3:07:51 PM by mik b

Cyberduck_2014-03-25-160205_Mikaels-MacBook-Pro.crash attached.

comment:8 follow-up: Changed on Mar 26, 2014 at 3:18:31 PM by raybengen

I didn't get a .crash so I pasted the crash report into a file and it's uploading

Changed on Mar 26, 2014 at 3:20:43 PM by raybengen

pasted file from crash report

comment:9 in reply to: ↑ 8 ; follow-up: Changed on Mar 26, 2014 at 4:36:16 PM by dkocher

Replying to raybengen:

I didn't get a .crash so I pasted the crash report into a file and it's uploading

The hang is in a system library converting TIFF images. I have no real idea what we can do about.

comment:10 in reply to: ↑ 7 ; follow-up: Changed on Mar 26, 2014 at 4:37:45 PM by dkocher

Replying to mik b:

Cyberduck_2014-03-25-160205_Mikaels-MacBook-Pro.crash attached.

This is a different issue than what was originally reported in this ticket. Can you reproduce this with the latest snapshot build available?

comment:11 in reply to: ↑ 10 Changed on Mar 26, 2014 at 8:10:43 PM by mik b

Replying to dkocher:

Replying to mik b:

Cyberduck_2014-03-25-160205_Mikaels-MacBook-Pro.crash attached.

This is a different issue than what was originally reported in this ticket. Can you reproduce this with the latest snapshot build available?

I can't get a crash now from Cyberduck 4.4.3 (14433) nor from the 4.4.3 I downloaded the other day. I'm not sure what is different except I ran the later version once. However, when I'm connected it takes 100 seconds for the preferences window to open. OK, scrap that. It takes 100 seconds anyway. During this time Cyberduck is not responsive. and I do get the beach ball if connected. This is normal?

Last edited on Mar 26, 2014 at 8:11:14 PM by mik b (previous) (diff)

comment:12 Changed on Mar 26, 2014 at 10:07:30 PM by raybengen

Same thing happens with 14433.tar.gz, devours all memory and then hangs...

comment:13 in reply to: ↑ 9 Changed on Mar 27, 2014 at 12:08:45 AM by raybengen

Replying to dkocher:

Replying to raybengen:

I didn't get a .crash so I pasted the crash report into a file and it's uploading

The hang is in a system library converting TIFF images. I have no real idea what we can do about.

Begs the question, why is Cyberduck messing around with TIFFs ?

comment:14 Changed on Apr 1, 2014 at 9:42:43 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

The slow loading of the preferences window is possibly due to slow lookups of editor applications and/or default protocol handlers using Launch Services framework in OS X. The reason these lookups take too long is out of our control, but we have changed the panels to initialize panel only after tab is selected in r14440. This will make the General tab view load immediately.

Note: See TracTickets for help on using tickets.
swiss made software