Cyberduck Mountain Duck CLI

#7846 closed defect (worksforme)

The server sent an invalid id field

Reported by: michael krasnow Owned by: dkocher
Priority: high Milestone: 4.4.4
Component: sftp Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description

Hi,

I have been using cyberduck for quite a while on the server I am connecting to, but I recently when attempting to download from my server I have been running into this issue where the transfer errors out and never ends: http://screencast.com/t/hYrHQsHMx

even after hitting cancel at the try again, it keeps going, I end up having to Force Quit.

the last thing in the log is:

SSH_FXP_READDIR
SSH_FXP_STATUS
SSH_FXP_CLOSE
SSH_FXP_STATUS

I authenticate using keys (no password)

When I download the same file using Fetch it works fine.

Change History (16)

comment:1 Changed on Mar 13, 2014 at 4:42:55 PM by michael krasnow

I just checked my console.app and I see this quite a bit:

3/13/14 12:40:31.004 PM Cyberduck[96851]: [main] ERROR org.rococoa.callback - Exception calling method for selector validateToolbarItem:

java.lang.reflect.InvocationTargetException
	at sun.reflect.GeneratedMethodAccessor33.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
	at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
	at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
	at sun.reflect.GeneratedMethodAccessor15.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:471)
	at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:501)
	at com.sun.jna.Native.invokeVoid(Native Method)
	at com.sun.jna.Function.invoke(Function.java:367)
	at com.sun.jna.Function.invoke(Function.java:315)
	at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
	at com.sun.jna.Library$Handler.invoke(Library.java:210)
	at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
	at org.rococoa.Foundation.send(Foundation.java:208)
	at org.rococoa.Foundation.send(Foundation.java:194)
	at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
	at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
	at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
	at ch.cyberduck.ui.cocoa.application.NSApplication$$ByRococoa.run(<generated>)
	at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:146)
Caused by: java.lang.NullPointerException
	at ch.cyberduck.core.transfer.Transfer.getLocal(Transfer.java:286)
	at ch.cyberduck.ui.cocoa.TransferController$14.validate(TransferController.java:1169)
	at ch.cyberduck.ui.cocoa.TransferController.validate(TransferController.java:1197)
	at ch.cyberduck.ui.cocoa.TransferController.validateItem(TransferController.java:1166)
	at ch.cyberduck.ui.cocoa.TransferController.validateToolbarItem(TransferController.java:1096)
	... 24 more

and

3/13/14 12:33:23.466 PM Cyberduck[79442]: [background-45] FATAL ch.cyberduck.ui.AbstractController - Unhandled exception running background task password argument is null

java.lang.IllegalArgumentException: password argument is null
	at ch.ethz.ssh2.Connection.authenticateWithPassword(Connection.java:338)
	at ch.cyberduck.core.sftp.SFTPPasswordAuthentication.authenticate(SFTPPasswordAuthentication.java:46)
	at ch.cyberduck.core.sftp.SFTPSession.login(SFTPSession.java:127)
	at ch.cyberduck.core.KeychainLoginService.login(KeychainLoginService.java:77)
	at ch.cyberduck.core.LoginConnectionService.connect(LoginConnectionService.java:143)
	at ch.cyberduck.core.LoginConnectionService.check(LoginConnectionService.java:83)
	at ch.cyberduck.core.threading.SessionBackgroundAction.connect(SessionBackgroundAction.java:175)
	at ch.cyberduck.ui.threading.TransferBackgroundAction.connect(TransferBackgroundAction.java:122)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:158)
	at ch.cyberduck.ui.AbstractController$BackgroundCallable.call(AbstractController.java:159)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:57)
	at java.lang.Thread.run(Thread.java:724)

Last edited on Mar 13, 2014 at 4:44:05 PM by michael krasnow (previous) (diff)

comment:2 Changed on Mar 13, 2014 at 4:59:07 PM by dkocher

  • Milestone set to 4.4.4
  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Mar 19, 2014 at 4:29:29 PM by dkocher

Please update to the latest snapshot build available.

comment:4 Changed on Mar 20, 2014 at 4:43:19 AM by michael krasnow

Not seeing those errors in my console.app, but I am still unable to download via sftp,

I am getting errors such as

The server sent an invalid id field.

comment:5 Changed on Mar 26, 2014 at 12:25:06 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

Please try the latest snapshot build (r14427 or later) available.

comment:6 Changed on Mar 27, 2014 at 3:05:21 PM by michael krasnow

On build 14433 and the issue persists.

comment:7 Changed on Mar 31, 2014 at 3:42:07 PM by michael krasnow

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed on Apr 1, 2014 at 9:49:27 AM by dkocher

Can you please post the latest entries in Console.app and the error message displayed with r14433.

comment:9 Changed on Apr 1, 2014 at 9:49:51 AM by dkocher

  • Component changed from core to sftp
  • Summary changed from Unable to download via SFTP to The server sent an invalid id field

comment:10 Changed on Apr 1, 2014 at 9:49:55 AM by dkocher

  • Status changed from reopened to new

comment:11 Changed on Apr 1, 2014 at 9:50:01 AM by dkocher

  • Status changed from new to assigned

comment:12 Changed on Apr 1, 2014 at 5:06:10 PM by michael krasnow

I don't see anything in the console.app, I am now on build r14440.

Last edited on Apr 1, 2014 at 6:25:09 PM by dkocher (previous) (diff)

comment:13 Changed on Apr 10, 2014 at 2:28:48 PM by dkocher

Please try r14478 or later.

comment:14 Changed on Apr 10, 2014 at 7:05:27 PM by michael krasnow

Browsing the server seems much better, but the error still appears, but after hitting continue a few times, it does start,

also, the transfers window would not show any information on launch, restarted cyberduck to the same effect, when starting the download a different download from months ago was the only thing in the transfers list.

Also, the transfers list had a spinny wheel in it the entire time:

http://screencast.com/t/V0Bfgpoqe

build r14478

EDIT: looks like anything I hit continue on did not download actually.

Last edited on Apr 10, 2014 at 7:10:09 PM by michael krasnow (previous) (diff)

comment:15 Changed on Apr 11, 2014 at 9:19:04 AM by dkocher

Is it possible to get temporary access to this server as we cannot replicate the issue here. Please contact dkocher@….

comment:16 Changed on Apr 16, 2014 at 9:53:29 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.
swiss made software