Cyberduck Mountain Duck CLI

#7849 closed defect (worksforme)

Exception in prompt login controller

Reported by: jjwjj Owned by: yla
Priority: normal Milestone: 4.4.4
Component: s3 Version: 4.4.3
Severity: blocker Keywords:
Cc: Architecture: Intel
Platform: Windows 8

Description

I've read the guidelines above, and am comfortable this is not an issue with my hosting service. As such, please give some credence to the info below:

I have used Cyberduck on OSX and Win7. I built a new machine this weekend with Win8.1, and I am unable to sign into my S3 account. My credentials are correct for S3 and I have verified that they work on other non-Win8.1 machines.

If I run Cyberduck on other machines from the same location with the same credentials, I do not experience issues. This appears to be a Cyberduck/Win8.1 issue. When trying to toggle the Log Drawer, I do not get any additional views.

Attachments (1)

cyberduck.log (52.2 KB) - added by jjwjj on Mar 20, 2014 at 1:54:12 AM.
cyberduck.log as requested

Download all attachments as: .zip

Change History (9)

comment:1 Changed on Mar 19, 2014 at 5:23:09 PM by dkocher

Plus attach the file cyberduck.log in the application support directory and any error message displayed.

comment:2 Changed on Mar 19, 2014 at 5:29:57 PM by dkocher

#7851 closed as duplicate.

Changed on Mar 20, 2014 at 1:54:12 AM by jjwjj

cyberduck.log as requested

comment:3 Changed on Mar 20, 2014 at 1:56:32 AM by jjwjj

Error Dialog Reads:

Login Failed
Listing directory failed. Please contact your web hosting service provider for assistance.

Again the same credentials work on other machines, and also work with the "S3 Browser" software package. Problem seems to be unique to Cyberduck on Win8.1

Last edited on Mar 21, 2014 at 2:31:31 PM by dkocher (previous) (diff)

comment:4 Changed on Mar 21, 2014 at 2:31:50 PM by dkocher

  • Milestone set to 4.4.4
  • Owner changed from dkocher to yla
  • Summary changed from Windows 8.1 and S3 interaction to Login failure

comment:5 Changed on Mar 26, 2014 at 2:11:40 PM by dkocher

2014-03-20 21:51:31,681 [background-1] ERROR AsyncController - Unhandled exception during invoke
null null
	at cli.Ch.Cyberduck.Ui.Controller.PromptLoginController$$$003C$$003Ec__DisplayClass5.<prompt>b__4(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.Threading.SimpleDefaultMainAction.run(Unknown Source)
	at cli.System.Delegate.DynamicInvokeImpl(Unknown Source)
	at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackDo(Unknown Source)
	at cli.System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Unknown Source)
	at cli.System.Threading.ExecutionContext.RunInternal(Unknown Source)
	at cli.System.Threading.ExecutionContext.Run(Unknown Source)
	at cli.System.Threading.ExecutionContext.Run(Unknown Source)
	at cli.System.Windows.Forms.Control.InvokeMarshaledCallback(Unknown Source)
	at cli.System.Windows.Forms.Control.InvokeMarshaledCallbacks(Unknown Source)
	at cli.System.Windows.Forms.Control.WndProc(Unknown Source)
	at cli.System.Windows.Forms.ScrollableControl.WndProc(Unknown Source)
	at cli.System.Windows.Forms.Form.WndProc(Unknown Source)
	at cli.System.Windows.Forms.Control$ControlNativeWindow.OnMessage(Unknown Source)
	at cli.System.Windows.Forms.Control$ControlNativeWindow.WndProc(Unknown Source)
	at cli.System.Windows.Forms.NativeWindow.Callback(Unknown Source)
	at cli.System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(Unknown Source)
	at cli.System.Windows.Forms.Application$ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Unknown Source)
	at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoopInner(Unknown Source)
	at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoop(Unknown Source)
	at cli.System.Windows.Forms.Application.Run(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Main(Unknown Source)

comment:6 Changed on Mar 26, 2014 at 3:40:29 PM by dkocher

  • Summary changed from Login failure to Exception in prompt login controller

comment:7 Changed on Mar 26, 2014 at 4:18:33 PM by dkocher

This stacktrace is expected when choosing Cancel in the login prompt.

comment:8 Changed on Apr 4, 2014 at 1:59:52 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

We cannot reproduce this issue also tested with Windows 8.1. Can you reproduce this issue with another Windows 8.1 installation?

Note: See TracTickets for help on using tickets.
swiss made software