Cyberduck Mountain Duck CLI

#7852 closed defect (fixed)

Uploading a folder stops when it reaches a symlink

Reported by: tihomir Owned by: dkocher
Priority: high Milestone: 4.4.4
Component: core Version: 4.4.3
Severity: normal Keywords: mac, symlink, symbolic, upload, folder, delete, remove
Cc: Architecture: Intel
Platform: Mac OS X 10.7

Description (last modified by tihomir)

I'm uploading a folder which contains a symbolic link. I'm expecting this link to be resolved and the actual file to be uploaded on the server. However the upload stops when it reaches the symlink and the rest of the files (and folders) are not uploaded.

I'm uploading the folder by command-C in Finder and command-V in CyberDuck.

If I try to upload just the symlink this way it does not work. However if I upload using the "select file for upload" dialog (option-up) I'm able to upload just that file.

I tried to delete the folder then and an empty placeholder remained (attached). I hit Refresh a few times. Nothing changed. I tried to upload the folder again (the same way — command-C, command-V) - nothing happened. Nothing has been uploaded. I restarted CyberDuck and I found the folder is there but again half-uploaded.

Currently CyberDuck is practically unusable for such folders and I have to use another way of doing my job. Maybe downgrading to a lower version...?

I'm using version 4.4.4 (just downloaded it).

Updated: Reverted back to 4.4.3. It uploads the folders without resolving the symbolic links which results files on the server that link to invalid locations and I have to manually go and upload every single symbollic link as a normal file.

Attachments (1)

Screen Shot 2014-03-18 at 8.59.05 PM.png (28.1 KB) - added by tihomir on Mar 18, 2014 at 7:03:26 PM.

Download all attachments as: .zip

Change History (4)

comment:1 Changed on Mar 18, 2014 at 7:12:36 PM by tihomir

  • Description modified (diff)

comment:2 Changed on Mar 19, 2014 at 4:36:43 PM by dkocher

  • Milestone set to 4.4.4
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Uploading a folder on Mac stops when it reaches a symlink to Uploading a folder stops when it reaches a symlink

comment:3 Changed on Mar 19, 2014 at 4:51:58 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r14396.

Note: See TracTickets for help on using tickets.
swiss made software